Bug 839827 (prassel)

youtube hd video lag while loading

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: prassel.b+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130206083616

Steps to reproduce:

Play HD (720p / 1080p) videos on YouTube.


Actual results:

Video completely freeze with large random frame skipping while the video is loading. Browser becomes sluggish and unresponsive.

Audio is not affected.


Expected results:

Smooth playback of the video at all times.
(Reporter)

Comment 1

5 years ago
This has been an issue since Flash v11.4 through all versions of Firefox since June 2012.
No issues with other browsers. No issues with Flash v11.3.

Solutions tried but failed to solve the issue:
* Upgrading Flash from 11.4 to 11.5.
* Turn hardware acceleration in Flash off.
* Turn hardware acceleration in Flash on.
* Deleting all data in Flash global settings.
* Clear all browser data such as cache, profiles, etc.
* Reinstalling Flash.
* Reinstalling Firefox.
* Upgrading Firefox.
* Restarting Firefox in safe-mode with all add-ons disabled.
Is the CPU Usage maxed out?
(Reporter)

Comment 3

5 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #2)
> Is the CPU Usage maxed out?

It stays under 70% while loading then drops after the video is fully loaded.

http://i.imgur.com/0rBPWgh.png
http://i.imgur.com/DTZGwFT.png

Comment 4

5 years ago
I can't reproduce this issue locally on Win 7 64bit. Considering this and the solutions you tried, I'm thinking this issue might have to do with your graphics board. Have you tried upgrading its driver?

When you get the chance, please also try and let us know if a clean profile fixes your problem:
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
http://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems?esab=a&s=reset+firefox&r=1&as=s (if you want to keep the data from your initial profile)
Flags: needinfo?(prassel.b+bugzilla)
(Reporter)

Comment 5

5 years ago
(In reply to Ioana Budnar [QA] from comment #4)
> I can't reproduce this issue locally on Win 7 64bit. Considering this and
> the solutions you tried, I'm thinking this issue might have to do with your
> graphics board. Have you tried upgrading its driver?
> 
> When you get the chance, please also try and let us know if a clean profile
> fixes your problem:
> http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles
> http://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-
> problems?esab=a&s=reset+firefox&r=1&as=s (if you want to keep the data from
> your initial profile)

I have tried at least 4 different graphics card driver versions since August 2012 when the issue appeared, including the latest as of this moment (310.90).
I have also tried a clean profile and resetting Firefox (I forgot to mention this).

What puzzles me is that if I right-click the video and select the 'pop-out' option, the videos play fine without any freezing or skipping.

Also I forgot to mention the issue also persisted after upgrading the CPU from a Core2Duo to a Core2Quad.

If you think it would help, I can try a different graphics card (AMD 6850, Nvidia 9800 and 9400) I have lying around. I can also try a spare computer (another Core2 Win7 x64 system) that I can put my current GPU in, and/or any of the other three.
Flags: needinfo?(prassel.b+bugzilla)
(Reporter)

Updated

5 years ago
Alias: prassel

Comment 6

5 years ago
Can you reproduce this issue if using HTML5 players?
http://youtube.com/html5
Flags: needinfo?(prassel.b+bugzilla)
(Reporter)

Comment 7

5 years ago
(In reply to Ioana Budnar [QA] from comment #6)
> Can you reproduce this issue if using HTML5 players?
> http://youtube.com/html5

Yes, since not all content is available in the HTML5 format.
Flags: needinfo?(prassel.b+bugzilla)

Comment 8

5 years ago
Can you reproduce it with content that is in HTML5 format? I'm trying to figure out if this is a Flash-related issue, so please try to reproduce it with HTML5 videos.
Flags: needinfo?(prassel.b+bugzilla)
(Reporter)

Comment 9

5 years ago
HTML5 content plays fine with no skipping or freezing.

The latest Flash update did not fix the issue.
Flags: needinfo?(prassel.b+bugzilla)

Comment 10

5 years ago
(In reply to prassel.b+bugzilla from comment #9)
> HTML5 content plays fine with no skipping or freezing.
> 
> The latest Flash update did not fix the issue.

Thanks, Prassel.
Component: Untriaged → Plug-ins
Product: Firefox → Core
Priority: -- → P3
(Reporter)

Comment 11

5 years ago
I just uninstalled all Nvidia drivers, changed my graphics card to AMD HD6850 and installed the latest drivers for that.

The issue still persists.

Comment 12

5 years ago
Normally, using Palemoon but same happens in Firefox 19.0.2.
It must be that Youtube's team changed the page again and the repainting problem is back.

Before it was okay for fast PCs, but slow ones were affected. This time I am experiencing the similar problem and I am running on the FX-4100 (3.6 GHZ) Quad-core.
So, I was going to rule in the Nvidia graphic card, runningGTX 660 card, or that I always use the latest Beta drivers, but prassel has overruled that thought.
Is this still an issue using latest Flash Player and Firefox Nightly ? nightly.mozilla.org
Flags: needinfo?(prassel.b+bugzilla)
(Reporter)

Comment 14

5 years ago
(In reply to Paul Silaghi, QA [:pauly] from comment #13)
> Is this still an issue using latest Flash Player and Firefox Nightly ?
> nightly.mozilla.org

Yes, but only slightly for a handful of seconds during the start of the video, or when you change the quality. 
It's not much of an issue any more.

Haven't tried Nightly.
Flags: needinfo?(prassel.b+bugzilla)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.