hosted+appcache > installState is always set to "installed" at reboot while it should stay "pending"

RESOLVED DUPLICATE of bug 839071

Status

RESOLVED DUPLICATE of bug 839071
6 years ago
a year ago

People

(Reporter: julienw, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:
* start the install of the app at http://everlong.org/mozilla/selfupdatinghosted/
* reboot the phone while downloading
=> we can see an appcache error in logs, which is expected.

Expected:
* at reboot, we have the "pending" icon

Actual:
* we have the app icon which means the phone thinks it is installed.
* looking in /data/local/webapps/webapps.json, we see the installState is "installed".

I'm not sure but I think the problem is: when we reboot, the phone is doing a checkForUpdate but we don't have the network yet, and for some reason, we reset the installState to "installed".

User impact: when the user will open the app, the appcache will be downloaded whereas he thinks the app is installed and so the appcache would be ready ot be used.
(Reporter)

Comment 1

6 years ago
Same result if we cancel the download before rebooting.

Updated

6 years ago
Blocks: 802574
(Reporter)

Comment 2

6 years ago
seems I like to open the same bug twice in 4 days.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839071

Updated

6 years ago
No longer blocks: 802574
tracking-b2g18: ? → ---

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.