dragging text from one window to other automatically makes it a URL and opens it.

RESOLVED INVALID

Status

()

Firefox
General
--
enhancement
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130209 Firefox/21.0
Build ID: 20130209031117

Steps to reproduce:

1. Start fresh profile.
2. Open en.wikipedia.org in two tabs.
3. Drag one of the tab outside, so that it becomes a new window with a single tab.  (at this stage you will have two windows, each with one tab, opening en.eikipedia.org)

4. arrange the two windows so that they are side-by-side.
5. Select a word from one of the windows, and drag and drop it anywhere in the other window.  (but not on the URL bar)



Actual results:

the selected word is automatically converted to a URL, and Firefox tries to open it. So if you select  "xyz" from the first window. and Dragged-and-dropped it, the other window will try to open "www.xyz.com"


Expected results:

Not really sure what should be the correct way to handle such case, but the dragged word should be treated as a URL *only*  when it is dragged-and-dropped in the URL bar.
(Reporter)

Updated

6 years ago
Component: Untriaged → DOM: CSS Object Model
Product: Firefox → Core
What does this have to do with the CSSOM?

Last I checked:

1)  The behavior is purposeful.
2)  It's front-end, not Core.
Component: DOM: CSS Object Model → General
Product: Core → Firefox
(Reporter)

Comment 2

6 years ago
sorry for the wrong categorization and the resulting bug spam.

Comment 3

6 years ago
Marking this bug as enhancement since the behavior is purposeful.

What happens if you drop the dragged text into a textbox or textarea?
Severity: normal → enhancement
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 4

6 years ago
(In reply to Ioana Budnar [QA] from comment #3)
> 
> 
> What happens if you drop the dragged text into a textbox or textarea?

It is dragged-and-dropped as normal text.
Flags: needinfo?(mayankleoboy1)

Comment 5

6 years ago
Thanks. That confirms that there are no issues with the current behavior.

You can leave this bug open as an enhancement request if you still want this behavior changed.
(Reporter)

Comment 6

3 years ago
this is intended behaviour.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.