TB shows only the first conversation

RESOLVED DUPLICATE of bug 839792

Status

Thunderbird
Instant Messaging
--
major
RESOLVED DUPLICATE of bug 839792
5 years ago
5 years ago

People

(Reporter: Paenglab, Assigned: florian)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Starting with Daily 2013-02-09-030514 only the first conversation is shown. All additional conversations are working but not accessible (receiving direct messages is shown on chat button but not readable).
Last good is 2013-02-08-030501

In console I see this:
Sun Feb 10 2013 14:17:34
Error: aContactA.displayName is undefined
Source file: chrome://messenger/content/chat/imgroup.xml
Line: 39
(Assignee)

Comment 1

5 years ago
Do we know what was checked in between these 2 nightlies that could cause the regression?
(Reporter)

Comment 2

5 years ago
On c-c I see only https://hg.mozilla.org/comm-central/rev/76972e8b8432 but this is unlikely the cause.

m-c has a lot: http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2013-02-08+03%3A05%3A01&enddate=2013-02-09+03%3A05%3A14
(Assignee)

Comment 3

5 years ago
Created attachment 713308 [details] [diff] [review]
Patch

I looked into this a bit. It turns out we are attempting to sort conversations with the contacts comparator from http://hg.mozilla.org/comm-central/annotate/d2957730cfd1/mail/components/im/content/imgroup.xml#l32 because http://hg.mozilla.org/comm-central/annotate/d2957730cfd1/mail/components/im/content/chat-messenger-overlay.js#l1022 fails with this warning:
JavaScript strict warning: chrome://messenger/content/chat/chat-messenger-overlay.js, line 1024: "sortComparator" is read-only

I think is a regression from http://hg.mozilla.org/mozilla-central/rev/5264dc88e9c2 (bug 821850, which I cannot access). I'm patching it like http://hg.mozilla.org/mozilla-central/diff/5264dc88e9c2/browser/base/content/test/browser_urlbarAutoFillTrimURLs.js
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #713308 - Flags: review?(clokep)
(Assignee)

Comment 4

5 years ago
I tried to mark this blocking bug 821850, but apparently it's not possible without being allowed to access the bug :-(.
Severity: normal → major
OS: Windows 7 → All
Hardware: x86_64 → All
Comment on attachment 713308 [details] [diff] [review]
Patch

This seems like an annoying change, do we think this bites us anywhere else? Would be nice if an error was thrown in the console.
Attachment #713308 - Flags: review?(clokep) → review+
(Assignee)

Comment 6

5 years ago
Cc'ing Bobby Holley who's the author of http://hg.mozilla.org/mozilla-central/rev/5264dc88e9c2

Bobby, I would just like to ensure that you are aware of the regressions that your changeset causes (I can't mark this bug as blocking bug 821850 myself).

I suspect making the XBL methods readonly has the potential for breaking lots of add-ons. For example I expect lots of tab browsing add-ons to mess with methods of tabbrowser.xml. Is there any plan to mitigate this? If not I think the changes should at least be very clearly documented to add-on authors.

Updated

5 years ago
Blocks: 821850
Flags: needinfo?(bobbyholley+bmo)

Comment 7

5 years ago
(In reply to Florian Quèze [:florian] [:flo] from comment #6)

> I suspect making the XBL methods readonly has the potential for breaking
> lots of add-ons. For example I expect lots of tab browsing add-ons to mess
> with methods of tabbrowser.xml.

Indeed even NoScript does it to patch the notification bar stuff in order to display notifications on the bottom, and to implement "sticky" menus.

If these cases are doomed under the new rules, couldn't we just apply this restriction to non-privileged callers?

Comment 8

5 years ago
Florian,
I didn't see a checkin of your patch. But the symptoms of this bug seems to have disappeared using a tinderbox build:
http://hg.mozilla.org/mozilla-central/rev/7bd555e2acfa
The only thing that I can guess at is that backout:
https://hg.mozilla.org/comm-central/rev/0879e29b38b9
was the real issue all along.
(Reporter)

Comment 9

5 years ago
Correct, it's working again also with 0215 Daily. It wasn't this backout because it was after Daily creation.
(In reply to Richard Marti [:Paenglab] from comment #9)
> Correct, it's working again also with 0215 Daily. It wasn't this backout
> because it was after Daily creation.

Yeah, I fixed this in bug 839792.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(bobbyholley+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 839792
You need to log in before you can comment on or make changes to this bug.