Text nodes in anonymous subtrees shouldn't affect ancestors with dir=auto

RESOLVED FIXED in mozilla22

Status

()

Core
Layout: Text
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: smontagu, Assigned: smontagu)

Tracking

unspecified
mozilla22
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
I filed https://www.w3.org/Bugs/Public/show_bug.cgi?id=20151 to confirm that text node descendants of <input> and other form controls shouldn't affect the direction of ancestors with dir=auto.

From Hixie's response in https://www.w3.org/Bugs/Public/show_bug.cgi?id=20151#c1, the answer was obvious all along: these descendants are not descendants, or only descendants in a Pickwickian sense, or something.
(Assignee)

Comment 1

5 years ago
Created attachment 712260 [details]
Testcase
Assignee: nobody → smontagu
(Assignee)

Comment 2

5 years ago
Created attachment 714285 [details] [diff] [review]
Patch
Attachment #714285 - Flags: review?(ehsan)

Updated

5 years ago
Attachment #714285 - Flags: review?(ehsan) → review+
(Assignee)

Updated

5 years ago
Flags: in-testsuite?
https://hg.mozilla.org/mozilla-central/rev/9a64d342d11b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla22

Updated

5 years ago
Duplicate of this bug: 873388
You need to log in before you can comment on or make changes to this bug.