changing calendar offline support (caching) state breaks the calendar list for right-clicking menu options

RESOLVED DUPLICATE of bug 974816

Status

Calendar
Calendar Views
RESOLVED DUPLICATE of bug 974816
5 years ago
4 years ago

People

(Reporter: Alexandre Demers, Unassigned)

Tracking

Lightning 1.9

Details

(Reporter)

Description

5 years ago
I have 4 calendars in my calendar list: a local, a network read only and two calDav (Google) ones. Caching is enabled on all my network calendars.

As an example, let's say I disable offline support for the third calendar (which is one of my CalDav),  right-clicking->properties on that same calendar in the calendar pane after that change will always bring the fourth calendar (the following in the list) properties.

It seems as if the action linked to the calendar selection is not pointing at the good calendar anymore. However, double-clicking on the calendar right after changing the offline support state will always bring the good calendar properties as expected.

Selecting a different calendar before right-clicking->properties on the original one (the third calendar in this example) will now show the good calendar properties. Is it possible the double-click action always check which calendar is selected, while the right-click->properties doesn't?

Tested on Windows, I will confirm on Linux.
This could be due to Bug 813476 which is fixed in the soon to be released Lightning 1.9.1 - could you test with that once it's released and report back if the problem persists?
(Reporter)

Comment 2

5 years ago
(In reply to Matthew Mecca [:mmecca] from comment #1)
> This could be due to Bug 813476 which is fixed in the soon to be released
> Lightning 1.9.1 - could you test with that once it's released and report
> back if the problem persists?

I will.
(Reporter)

Comment 3

5 years ago
It's not related to bug 813476 or its fix: I'm testing Lightning 1.9.1 and I can reproduce it exactly as before.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 974816
You need to log in before you can comment on or make changes to this bug.