[Trunk]Crash [@ CheckForFocus]

VERIFIED FIXED

Status

()

Core
Layout
P1
critical
VERIFIED FIXED
17 years ago
5 years ago

People

(Reporter: Shiva Thirumazhusai, Assigned: Marc Attinasi)

Tracking

({crash, topcrash})

Trunk
x86
Windows NT
crash, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
This crash is one of the topcrash reported by talkback system.
Seems to be happening when running in turbo mode invocation. 

Stack Trace: 

         CheckForFocus  
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 2399]
         PresShell::UnsuppressAndInvalidate     
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 4492]
         PresShell::ProcessReflowCommands       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5853]
         ReflowEvent::HandleEvent       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5626]
         PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  
line 591]
         PL_ProcessPendingEvents        
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524]
         _md_EventReceiverProc  
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
         nsAppShellService::Run 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 418]
         main1  [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  
line 1135]
         main   [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  
line 1429]
         WinMain        
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1447]
         WinMainCRTStartup()
         KERNEL32.DLL + 0x7903 (0x77e87903)
    CheckForFocus 6294d3a1
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2399
        Build: 2001060222 CrashDate: 2001-06-03 UptimeMinutes: 91  Total: 91 
        OS: Windows NT  5.0 build 2195
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31270112
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31270112

    CheckForFocus 01983654
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2395
        Build: 2001060109 CrashDate: 2001-06-03 UptimeMinutes: 928  Total: 1058 
        OS: Windows NT  5.0 build 2195
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31261686
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31261686
     (31261686) URL: www.deka.de
     (31261686) Comments: surfing ssl secured pages

    CheckForFocus 3bb8515f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2399
        Build: 2001060122 CrashDate: 2001-06-02 UptimeMinutes: 60  Total: 117 
        OS: Windows 98  4.10 build 67766222
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31237232
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31237232

    CheckForFocus 207af0d8
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2395
        Build: 2001060109 CrashDate: 2001-06-02 UptimeMinutes: 53  Total: 84 
        OS: Windows 98  4.90 build 73010104
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31236269
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31236269

    CheckForFocus bf36af74
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2399
        Build: 2001060122 CrashDate: 2001-06-02 UptimeMinutes: 20  Total: 20 
        OS: Windows 98  4.90 build 73010104
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31227072
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31227072

    CheckForFocus 3bb8515f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2399
        Build: 2001060122 CrashDate: 2001-06-02 UptimeMinutes: 51  Total: 57 
        OS: Windows 98  4.10 build 67766222
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31223496
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31223496

    CheckForFocus 3bb8515f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2399
        Build: 2001060122 CrashDate: 2001-06-02 UptimeMinutes: 5  Total: 5 
        OS: Windows 98  4.10 build 67766222
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31221630
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31221630

    CheckForFocus 1ab03b2c
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2399
        Build: 2001060122 CrashDate: 2001-06-02 UptimeMinutes: 4  Total: 4 
        OS: Windows NT  5.0 build 2195
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31217710
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31217710
     (31217710) Comments: mozilla -turbo

    CheckForFocus 48b0b8ca
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2395
        Build: 2001060109 CrashDate: 2001-06-02 UptimeMinutes: 3  Total: 95 
        OS: Windows 98  4.10 build 67766446
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31217307
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31217307
     (31217307) URL: http://www.tichk.org/

    CheckForFocus 48b0b8ca
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2395
        Build: 2001060109 CrashDate: 2001-06-01 UptimeMinutes: 0  Total: 92 
        OS: Windows 98  4.10 build 67766446
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31216855
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31216855
     (31216855) URL: http://www.tichk.org/

    CheckForFocus 48b0b8ca
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2395
        Build: 2001060109 CrashDate: 2001-06-01 UptimeMinutes: 1  Total: 91 
        OS: Windows 98  4.10 build 67766446
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31216831
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31216831

    CheckForFocus 48b0b8ca
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2395
        Build: 2001060109 CrashDate: 2001-06-01 UptimeMinutes: 40  Total: 90 
        OS: Windows 98  4.10 build 67766446
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31216809
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31216809

    CheckForFocus e7fe1093
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsPresS
hell.cpp line 2395
        Build: 2001060109 CrashDate: 2001-06-01 UptimeMinutes: 31  Total: 31 
        OS: Windows 98  4.90 build 73010104
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31215588
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31215588
(Reporter)

Comment 1

17 years ago
adding keywords crash and topcrash.
Keywords: crash, topcrash

Updated

17 years ago
Summary: Crashes at Trunk[@ CheckForFocus] → [Trunk]using preloader Crashes [@ CheckForFocus]

Comment 2

17 years ago
nav triage team:

Update summary to "-turbo mode", marking p1, mozilla0.9.2, and reassigning to 
pchen
Assignee: law → pchen
Priority: -- → P1
Summary: [Trunk]using preloader Crashes [@ CheckForFocus] → [Trunk]using -turbo mode Crashes [@ CheckForFocus]
Target Milestone: --- → mozilla0.9.2

Updated

17 years ago
Blocks: 75599

Comment 3

17 years ago
nav triage team:

Forgot nsbeta1+
Keywords: nsbeta1+
Paul, can you move this to the top of your list? thanks, Vishy
Whiteboard: no eta yet

Comment 5

17 years ago
After looking over a lot of the talkback reports, I wouldn't call this an -turbo 
mode only bug. Looks like a legit layout/presshell problem. Reassigning to 
layout. Removing + from nsbeta1 and resetting target milestone.
Assignee: pchen → karnaze
Component: Browser-General → Layout
Keywords: nsbeta1+ → nsbeta1
QA Contact: doronr → petersen
Summary: [Trunk]using -turbo mode Crashes [@ CheckForFocus] → [Trunk]Crash [@ CheckForFocus]
Whiteboard: no eta yet
Target Milestone: mozilla0.9.2 → ---

Updated

17 years ago
Keywords: nsenterprise

Comment 6

17 years ago
karnaze is out of office till 7/10/01.
get marc to help us take a look at this...
Assignee: karnaze → attinasi
(Assignee)

Comment 7

17 years ago
I'll take a look...
(Assignee)

Comment 8

17 years ago
The section of code that these talkbacks reference has been updated and fixed
already. These talkbacks are all before the third of June, and on 06/03 Hyatt
fixed some code in CheckForFocus that takes care of checking params better and
in all likelihood fixed this.

In particular, there was a blind-deref at line 2399 of ourWindow  and that is
probably the cause of these talkbacks. that has all been fixed, so marking FIXED
based on the CVS logs for nsPresShell. If this shows up in talkback past the 3rd
of June, please reopen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 75599

Updated

16 years ago
Blocks: 75599
Crash Signature: [@ CheckForFocus]
Blocks: 833994
You need to log in before you can comment on or make changes to this bug.