Last Comment Bug 840052 - EmbedSVG is broken
: EmbedSVG is broken
Status: RESOLVED FIXED
[specification][type:bug]
:
Product: Mozilla Developer Network
Classification: Other
Component: General (show other bugs)
: unspecified
: All Other
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-11 06:58 PST by Luke Crouch [:groovecoder]
Modified: 2013-02-12 12:02 PST (History)
0 users
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Luke Crouch [:groovecoder] 2013-02-11 06:58:52 PST
What did you do?
================
1. Go to https://developer.mozilla.org/en-US/docs/SVG/Element/polygon

What happened?
==============
Nothing shown in "Output results" column; the iframe src is ''

What should have happened?
==========================
Should see https://mdn.mozillademos.org/files/3259/polygon.svg in the iframe src.

Is there anything else we should know?
======================================
Template code is here: https://developer.mozilla.org/en-US/docs/Template:EmbedSVG
Comment 1 Luke Crouch [:groovecoder] 2013-02-11 11:16:58 PST
env.files.url value is coming thru as '/files/4623/polygon.svg' which is stripped by the IframeHostFilter at https://github.com/mozilla/kuma/blob/master/apps/wiki/content.py#L687-707

https://github.com/mozilla/kuma/pull/847 alters this to be https://mdn.mozillademos.org/files/4623/polygon.svg which is in KUMA_CODE_SAMPLE_HOSTS so it should be fine after that.
Comment 2 [github robot] 2013-02-12 12:02:39 PST
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/d79c7ee0536703c11ed23434ce8e435791cec9d4
fix bug 840052 - let DOMAIN iframe attachments

https://github.com/mozilla/kuma/commit/fc70f2e912dbb2798644cbe7f90cdc88dced230b
Merge pull request #855 from groovecoder/attachment-iframe-840052

fix bug 840052 - let DOMAIN iframe attachments

Note You need to log in before you can comment on or make changes to this bug.