Status

Mozilla Developer Network
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: groovecoder, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

5 years ago
What did you do?
================
1. Go to https://developer.mozilla.org/en-US/docs/SVG/Element/polygon

What happened?
==============
Nothing shown in "Output results" column; the iframe src is ''

What should have happened?
==========================
Should see https://mdn.mozillademos.org/files/3259/polygon.svg in the iframe src.

Is there anything else we should know?
======================================
Template code is here: https://developer.mozilla.org/en-US/docs/Template:EmbedSVG
(Reporter)

Comment 1

5 years ago
env.files.url value is coming thru as '/files/4623/polygon.svg' which is stripped by the IframeHostFilter at https://github.com/mozilla/kuma/blob/master/apps/wiki/content.py#L687-707

https://github.com/mozilla/kuma/pull/847 alters this to be https://mdn.mozillademos.org/files/4623/polygon.svg which is in KUMA_CODE_SAMPLE_HOSTS so it should be fine after that.

Comment 2

5 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/d79c7ee0536703c11ed23434ce8e435791cec9d4
fix bug 840052 - let DOMAIN iframe attachments

https://github.com/mozilla/kuma/commit/fc70f2e912dbb2798644cbe7f90cdc88dced230b
Merge pull request #855 from groovecoder/attachment-iframe-840052

fix bug 840052 - let DOMAIN iframe attachments

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.