Closed Bug 840056 Opened 8 years ago Closed 7 years ago

[MMS][User Story] Audio playback from message

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 CS (11may)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: pdol, Assigned: gnarf)

References

()

Details

(Keywords: feature, relnote, Whiteboard: [LOE:M],relnote-b2g:1.1+)

Attachments

(2 files)

UCID: Messages-055

User Story:
As a user, I want to be able to initiate the playback of audio directly from a message (sent or received).
Blocks: 840057
No longer blocks: 840057
Assignee: nobody → boaz
Whiteboard: u=user c=messaging s=v1.1-sprint-3
Assignee: boaz → cassie
Whiteboard: u=user c=messaging s=v1.1-sprint-3 → [LOE:M] u=user c=messaging s=v1.1-sprint-3
Assignee: cassie → danheberden
Depends on: 845996
Whiteboard: [LOE:M] u=user c=messaging s=v1.1-sprint-3 → [LOE:M]
What is a common use case for sending audio using MMS?   Do you think that it's appropriate to use the standard music player layout for this or do you think we need to design new play controls to play-in-place within a message?

Flagging Peter for more info
Flags: needinfo?(pdolanjski)
I think it's appropriate to keep the experience consistent and implement the std music player, but it may be something we want to revisit later (or if it's a simpler implementation).
Flags: needinfo?(pdolanjski)
Per partner and release-driver discussions, marking blocking- until all MMS functionality in bug 849867 is complete, allowing it all to be uplifted at once to avoid SMS bustage.
blocking-b2g: leo+ → -
After talking with Taipei, implementing using music player activity would also require the least effort.

We'll move forward with using this method.
Flags: in-moztrap?
leo+ as this is a part of MMS and part of v1.1 to be included in leo+ queries. No_UPLIFT for now before the whole MMS is completed
blocking-b2g: - → leo+
Whiteboard: [LOE:M] → [LOE:M] [NO_UPLIFT]
Right now, Ayman is redefining the playback related functionality on MMS Wireframes based on the Browser Downloading ones done by Rob https://www.dropbox.com/s/aolxy3mzrdfvg17/browser-downloading.pdf 
Due to that, we believe they are a good starting point to start the implementation of those capabilities. 

A rough description of the expected behaviour:

When an MMS contains an audio file, a visual indication should be shown to indicate the availability of such a content. When the user taps on that visual indication, the proper "view activity" is invoked and the following is done by the "handler" activity: 

The audio file is opened by the media player, while the sound is played in the music player, the user has the option to "save" that content, if the user selects that option, a banner indicating the success/failure of the operation is shown when completed. If the user cancels the "play" operation, he is returned to the thread detail screen in SMS Application. All this code should be implemented by an activity (I suppose in the audio player). 

If the audio file has not been properly retrieved, this option will not be offered to end-users. If that is the case, the attachment will indicate there was an error. Clicking on that indication will ask the user for confirmation to try to download the file ("There was an error downloading attachment. Retry Download?").
Depends on: 844431
No longer depends on: b2g-mms-dom-api
Assignee: danheberden → gnarf37
As agreed in Madrid assigned to Steve https://wiki.mozilla.org/Gaia/SMS by now.
Assignee: gnarf37 → schung
Whiteboard: [LOE:M] [NO_UPLIFT] → [LOE:M]
Depends on: 847006
Assignee: schung → gnarf37
It seems audio/amr is really common (bug 847006), no one can actually send me anything else it seems, so this is pretty much impossible to test on a device at the moment, but I will submit a patch.

We will need an image to represent an audio file in an mms, I currently have only a placeholder in place which I stole from our music app.
Flags: needinfo?(vpg)
Should get an image asset before we land this
Attachment #743938 - Flags: review?(felash)
Depends on: 867448
(In reply to Corey Frang [:gnarf] from comment #8)
> It seems audio/amr is really common (bug 847006), no one can actually send
> me anything else it seems, so this is pretty much impossible to test on a
> device at the moment, but I will submit a patch.
> 
> We will need an image to represent an audio file in an mms, I currently have
> only a placeholder in place which I stole from our music app.

Hi Corey, 
This is still work in progress but I am attaching the image, use it if you can easily update it later, if not, please wait to the definite one.

Thanks!

PS. assets live here: https://www.dropbox.com/sh/rdbkf2o2w2h1udu/TNnUzdT2Rq
Flags: needinfo?(vpg)
Target Milestone: --- → 1.1 CS (11may)
(In reply to Victoria Gerchinhoren from comment #10)
> 
> This is still work in progress but I am attaching the image, use it if you
> can easily update it later, if not, please wait to the definite one.
> 

It is easy to update later, just open a new bug about it!
(In reply to Corey Frang [:gnarf] from comment #12)
> (In reply to Victoria Gerchinhoren from comment #10)
> > 
> > This is still work in progress but I am attaching the image, use it if you
> > can easily update it later, if not, please wait to the definite one.
> > 
> 
> It is easy to update later, just open a new bug about it!

Yes, treat this as final, we're going with it. 
Thanks!
master: 50b73f78ed93496039039d9af64cdc6dba9803c2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Uplifted 50b73f78ed93496039039d9af64cdc6dba9803c2 to:
v1-train: 5f640a73f69e3b7e9f31662479e5d1825d5f274c
Blocks: 840057
Flags: in-moztrap? → in-moztrap+
Keywords: relnote
Whiteboard: [LOE:M] → [LOE:M],relnote-b2g:1.1+
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.