Closed Bug 840057 Opened 8 years ago Closed 7 years ago

[MMS][User Story] Video playback from message

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 CS (11may)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: pdol, Assigned: gnarf)

References

()

Details

(Keywords: feature, relnote, Whiteboard: relnote-b2g:1.1+)

Attachments

(2 files)

UCID: Messages-056

User Story:
As a user, I want to be able to initiate the playback of video directly from a message (sent or received).
No longer depends on: 840056
Assignee: nobody → boaz
Assignee: boaz → waldron.rick
Just taking notes for myself.

...within some DOM handler...

new MozActivity({ 
  name: 'view',
  data: { 
    type: 'url', 
    url: video url 
  }
});
+1 to Rick. We should use available activities on the device.
Per partner and release-driver discussions, marking blocking- until all MMS functionality in bug 849867 is complete, allowing it all to be uplifted at once to avoid SMS bustage.
blocking-b2g: leo+ → -
Flags: in-moztrap?
leo+ as this is a part of MMS and part of v1.1 to be included in leo+ queries. No_UPLIFT for now before the whole MMS is completed
blocking-b2g: - → leo+
Whiteboard: [NO_UPLIFT]
Right now, Ayman is redefining the playback related functionality on MMS Wireframes based on the Browser Downloading ones done by Rob https://www.dropbox.com/s/aolxy3mzrdfvg17/browser-downloading.pdf 
Due to that, we believe they are a good starting point to start the implementation of those capabilities. 

A rough description of the expected behaviour:
When an MMS contains a video file, a visual indication should be shown to indicate the availability of such a content. When the user taps on that visual indication, the proper "view activity" is invoked and the following is done by the "handler" activity: 


The video file is opened by the video player, while the video is played in the video player, the user has the option to "save" that content, if the user selects that option, a banner indicating the success/failure of the operation is shown when completed. If the user cancels the "play" operation, he is returned to the thread detail screen in SMS Application. All this code should be implemented by an activity (I suppose in the video player). 


If the video file has not been properly retrieved, this option will not be offered to end-users. If that is the case, the attachment will indicate there was an error. Clicking on that indication will ask the user for confirmation to try to download the file ("There was an error downloading attachment. Retry Download?").
Depends on: 844431
No longer depends on: b2g-mms-dom-api
As agreed in Madrid assigned to Steve https://wiki.mozilla.org/Gaia/SMS by now.
Assignee: waldron.rick → schung
Whiteboard: [NO_UPLIFT]
We will require an image to overlay on top of the video preview - Adding Victoria for this.
Flags: needinfo?(vpg)
(In reply to Corey Frang [:gnarf] from comment #7)
> We will require an image to overlay on top of the video preview - Adding
> Victoria for this.

Hi Corey,
Attaching the play icon in sprite, assets live here:
https://www.dropbox.com/sh/rdbkf2o2w2h1udu/TNnUzdT2Rq
Flags: needinfo?(vpg)
Target Milestone: --- → 1.1 CS (11may)
Assignee: schung → gnarf37
I notice that the test case only has a .ogv video in it. Does the MMS process involve transcoding so you know that you'll always be receiving this format? If not, I'd suggest you test with the .3gp videos that the user will be taking with the camera app...

And if you will be receiving .3gp videos there is all kinds of crazy you have to go through to get a preview image, including the deprecated-hwvideo permission and using shared/js/media/get_video_rotation.js to display the preview properly rotated. If you're just displaying a play button and a filename or something then you're okay, but if you need an actually poster image from the video, that's hard. I've done it for three different apps, so let me know if you need help with that.

And in particular, if the MMS app will have the deprecated-hwvideo permission then you have to take extra steps to play nice with Camera, Gallery and Video because of hardware contention issues.
(In reply to David Flanagan [:djf] from comment #11)
> And if you will be receiving .3gp videos there is all kinds of crazy you
> have to go through to get a preview image, including the deprecated-hwvideo
> permission and using shared/js/media/get_video_rotation.js to display the
> preview properly rotated. If you're just displaying a play button and a
> filename or something then you're okay, but if you need an actually poster
> image from the video, that's hard. I've done it for three different apps, so
> let me know if you need help with that.

I actually wouldn't mind your eyes & hands on the preview of videos.

I just made it a play button overlay on top of a video element, and was kinda upset that the video itself doesn't seem to show up in a `<video src=''>`... This just seemed like a failing of Gecko, not a place where I should have to write any code though.  IMO we shouldn't need any code gaia side to preview 3gp using a video tag, and if we do, that needs to be fixed in gecko.  Maybe I'm missing some obvious issue with that plan though...
Please file a bug in Gecko if you think there is something missing.

We might need to workaround this before it is fixed though.
reviewed on the PR

this is not bad, but we badly need UX input on this.
We agree that we are going to move forward without the preview. This will be fixed here https://bugzilla.mozilla.org/show_bug.cgi?id=869244.
Blocks: 869244
Comment on attachment 744878 [details] [diff] [review]
https://github.com/mozilla-b2g/gaia/pull/9523

This code is ready! Thanks Corey for the patch.
Attachment #744878 - Flags: review?(felash) → review+
Depends on: 840056, 840059
Uplifted 3dad6659d92eed2a6097deb2e7bf52015d037269 to:
v1-train: 5f63bf6808a17eb43c4fe7894171f35816e7ac9d
Attachment #744878 - Attachment is patch: true
Flags: in-moztrap? → in-moztrap+
Keywords: relnote
Whiteboard: relnote-b2g:1.1+
You need to log in before you can comment on or make changes to this bug.