Status

()

Core
XUL
--
critical
VERIFIED DUPLICATE of bug 83974
17 years ago
10 years ago

People

(Reporter: Dan M, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
With a browser window open, hit the "alt" key, as if you were about to open a 
menu using a keyboard shortcut. Boom (when you let go of the key, or hit another 
key, like alt-f).

Most likely this was introduced in rev 1.74 of nsMenuBarFrame.cpp, which contains 
amusing code like this:

nsMenuBarFrame::FindMenuWithShortcut(PRUint32 aLetter) {
 ...
 GetInsertionPoint(shell, this, nsnull, &immediateParent);
 ...
}
nsMenuBarFrame::GetInsertionPoint(nsIPresShell* aShell, nsIFrame* aFrame,
                nsIFrame* aChild, nsIFrame** aResult) {
 ...
 aChild->GetContent(getter_AddRefs(child));
 ...
}

you see the problem. The call to aChild was added in rev 1.74 to fix bugs 80512 
and bug 83707. The previous rev was simply missing the call. A null check would 
seem to fix this crash, but regress those other bugs.
(Reporter)

Comment 1

17 years ago


*** This bug has been marked as a duplicate of 83974 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.