Closed Bug 840270 Opened 9 years ago Closed 9 years ago

Work - Don't show a popup for <select multiple> when using precise pointer input (mouse/pen)

Categories

(Firefox for Metro Graveyard :: Input, defect)

All
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

()

Details

(Keywords: polish, Whiteboard: [metro-mvp+])

Attachments

(2 files)

Metro Firefox shows a popup for <select multiple> and <select size="n"> fields (where n > 1).  This is useful for touch, but it's not needed (and potentially confusing) for mouse and pen input.

We should probably suppress the popup and revert to normal mouse interaction when using a precise pointing device and interacting with <select multiple> and <select size="n"> fields?

This may be tricky to do without regressing bug 685197.
This is also a problem for the simple <select> because we show the touch pop-up instead of the precision pop-up. Is that covered here as well?
Summary: Don't show a popup for <select multiple> when using precise pointer input (mouse/pen) → Work - Don't show a popup for <select multiple> when using precise pointer input (mouse/pen)
Whiteboard: [metro-mvp?] → [metro-mvp+]
(In reply to Asa Dotzler [:asa] from comment #1)
> This is also a problem for the simple <select> because we show the touch
> pop-up instead of the precision pop-up. Is that covered here as well?

We can't show the actual classic-Firefox popup in Metro for technical reasons (we can't create popup widgets), but we could style the Metro popup to look like the classic one for mouse input.  We should file a separate bug if we want to do that.
Attached patch patchSplinter Review
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #714911 - Flags: review?(jmathies)
Attachment #714911 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/fa528f1db0d5

Hmm, after landing this I noticed some cases where the popup still intermittently appeared while using the mouse, but now I can't figure out how to reproduce that.  Also, if you switch from mouse to touch, it can takes the browser a moment to "notice" and switch to using the popup.  Might need some follow-up bugs.
Also needs tests.
Flags: in-testsuite?
https://hg.mozilla.org/mozilla-central/rev/fa528f1db0d5
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Attached patch follow-up fixSplinter Review
A trivial follow-up to fix some invalid CSS syntax that might have caused some of the issues noted above.
Attachment #716122 - Flags: review?(jmathies)
Attachment #716122 - Flags: review?(jmathies) → review+
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.