If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser (then entire computer) hangs when profiling sending emails from yahoo

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
--
major
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Reproducible on the latest Aurora (BuildID: 20130211042016): Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130211 Firefox/20.0
Reproducible on the latest Nightly (BuildID: 20130211031055): Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130211 Firefox/21.0

Steps to reproduce:
1. Open Profiler and start profiling
2. Log in to Yahoo mail
3. Press Compose 
4. Fill in recipient, subject and some text in email body
5. Press Send button

Expected results: Email sending completes successfully. Browser (and computer) can be used afterwards.

Actual results: Browser hangs while sending email. After a while, all computer hangs (not responding; it needs restart).

Notes:
1. This issue is not a regression; it reproduces with the first Nightly build when Profiler was introduced.
2. There are short hangs after step 3, but it usually recovers after a few seconds.
3. Once all computer hanged after step 3.
4. On Dec 16 Nightly build (when the Profiler was introduced), I also got an unresponsive script alert.
5. Email gets to the recipient.
6. Issue is not reproducible on Mac (10.7.5, 32 and 64bit mode) nor Windows (7-32bit).
(Reporter)

Updated

5 years ago
Severity: normal → major
Keywords: hang
Can you open a process monitor to see what is happening with IO, CPU usage, and Memory usage while this is happening?
(Reporter)

Comment 2

5 years ago
Created attachment 715902 [details]
system monitor

CPU usage goes up to 100%, while memory seems to be unaffected (~160MB for firefox process, similar to just having yahoo mail open and profiler running, without doing anything).
Thanks! Could you try to reproduce that with the Gecko Profiler addon? This way we'll know for sure whether to send this over to platform people or deal with it ourselves.

Gecko Profiler addon: https://addons.mozilla.org/en-us/firefox/addon/gecko-profiler/
(Reporter)

Comment 4

5 years ago
It seems that the add-on is not available for Linux (this is the only platform where I reproduced the bug)
That's a known AMO bug, the add-on is cross-platform. You can install it straight from the repo:

https://github.com/bgirard/Gecko-Profiler-Addon/raw/master/geckoprofiler.xpi
(Reporter)

Comment 6

5 years ago
It's reproducible with the add-on, as well (tested on latest Nightly 22.0a1).
Thanks Mihaela! I'll ping someone on the platform side.
CC'ing BenWa. Can you have any luck reproducing this? I suspect this might be difficult without a closer configuration to the reporter's.

Mihaela, can you give us some more details about your machine? OS version, CPU configuration, etc?
Flags: needinfo?(mihaela.velimiroviciu)
This must be another case of the profiler interrupting syscall and hanging. I don't have a yahoo account. Can you try 'gdb attach <FIREFOX PID>' when it's hung and try 'where' and paste the trace here?
(Reporter)

Comment 10

4 years ago
I could not reproduce this issue anymore on the latest Nightly: Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20130716 Firefox/25.0

Do you still need the info requested in comment #9?

My configuration is:
* OS: Ubuntu 13.04 x86
* CPU: Intel Core i5-3470 @3.2GHz x 4
* Memory: 4GB
* Graphics: AMD Radeon HD 7700 Series
Flags: needinfo?(mihaela.velimiroviciu)
Thanks Mihaela. That's great. Also, not exactly an under-powered computer like I was expecting.
(In reply to Mihaela Velimiroviciu [QA] (:mihaelav) from comment #10)
> I could not reproduce this issue anymore on the latest Nightly: Mozilla/5.0
> (X11; Linux i686; rv:25.0) Gecko/20130716 Firefox/25.0
> 
> Do you still need the info requested in comment #9?
> 
> My configuration is:
> * OS: Ubuntu 13.04 x86
> * CPU: Intel Core i5-3470 @3.2GHz x 4
> * Memory: 4GB
> * Graphics: AMD Radeon HD 7700 Series

can you try BenWa's suggestion from comment 9?

type ps auxc | grep firefox to get the PID of the currently-wedged Firefox process.
Since Mihaela can't reproduce the issue anymore I'm going to close the bug. Feel free to re-open it if the issue occurs again.

(I also tried to send an email from my old Yahoo! account while profiling the site and it didn't crash)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.