Fennec 18.0.2 missing from ftp.mozilla.org:/pub/mozilla.org/mobile/releases

RESOLVED FIXED

Status

Release Engineering
Release Requests
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Pedro Alves, Assigned: Callek)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Metrics scrapes ftp site to know when releases happens, and that has successfully replaced the old manual notification that releng had to send for us to manually add it to the DW.

We noticed however that we're missing 18.0.2 from
ftp.mozilla.org:/pub/mozilla.org/mobile/releases

... so we didn't notice it was released.


Is this the expected behavior? Should we rethink the way we detect versions?
(Assignee)

Comment 1

5 years ago
It was not expected behavior, and seems to be that one-of-us releng folk missed a step.

Its not required for users, but is required from expectations of us (such as yours)

What we missed was: https://wiki.mozilla.org/Release:Release_Automation_on_Mercurial:Updates#Push_the_files

I went ahead and did that just now for Fennec 18.0.2

I'm also on the hook for 19.0 so will make sure it happens, and will bring it up at the releng release post-mortem later today.

-- Thanks for the report.
Assignee: server-ops-releng → bugspam.Callek
Blocks: 838930
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: Server Operations: RelEng → Release Engineering: Releases
QA Contact: arich → bhearsum
Resolution: --- → FIXED
(Assignee)

Comment 2

5 years ago
Just noticed bug summary mentioned 18.0.1 -- there was no Mobile 18.0.1
Summary: Fennec 18.0.1 and 18.0.2 missing from ftp.mozilla.org:/pub/mozilla.org/mobile/releases → Fennec 18.0.2 missing from ftp.mozilla.org:/pub/mozilla.org/mobile/releases
This would be less difficult to forget about if we fixed https://bugzilla.mozilla.org/show_bug.cgi?id=543109.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.