Bug 840515 (mms-by-email)

[User Story][Messages] Send to Email address (FxOS 2.2)

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
P1
normal
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: pdol, Unassigned)

Tracking

({feature})

unspecified
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph
Bug Flags:
in-moztrap ?

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [ucid:Comms31, ft:comms] [m+][priority])

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
UCID: Messages-030

User Story:
As a user, I can compose an MMS message to an email address
(Reporter)

Updated

5 years ago
Summary: [MMS][User Story] MMS to Email address → [SMS/MMS][User Story] MMS to Email address
Clearing tracking-b2g18 flag from User Story bugs. This flag is for bugs that we would take fixes for in the 1.x branch. Feature work should be officially slotted into a release instead with leo+. If this story is intended for v1.1, please nominate for leo? blocking.
tracking-b2g18: + → ---
As is now, this will not be within the v1.1 MMS scope.
Duplicate of this bug: 897416
Duplicate of this bug: 897387
Moving the acceptance Criteria over to this bug:

Acceptance Criteria:
* Send a MMS (image, audio, text and video) to an e-mail account, verify that it correctly arrives to that e-mail account as an attachment
* Send a MMS to multiple recipients:
** only e-mail accounts
** e-mail accounts and phone numbers 
*** verify that it correctly arrives to all the recipients
add to backlog 891754
Blocks: 891754
Duplicate of this bug: 907140

Updated

5 years ago
Blocks: 903330
Summary: [SMS/MMS][User Story] MMS to Email address → [Messages][User Story] MMS to Email address

Comment 8

4 years ago
Dears,

Since this will not be within the v1.1 MMS scope, when do you think will have this?
this is one of the target items at the moment for v1.3
(In reply to Wilfred Mathanaraj [:WDM] from comment #9)
> this is one of the target items at the moment for v1.3
I would like to vote for this feature to be added soon in the roadmap. Please avoid any delay after v1.3.
We had received this request from some carriers. Thanks.
Depends on: 866938
Is support already implemented in mozMobileMessage.sendMMS? Once that's complete, this should be trivial.
(In reply to Rick Waldron from comment #11)
> Is support already implemented in mozMobileMessage.sendMMS? Once that's
> complete, this should be trivial.

Bug 866938 is under way to support. Gaia will be able to directly call sendMMS with e-mail addresses.
Blocks: 917190
No longer blocks: 891754, 903330, 919995
Severity: normal → blocker
blocking-b2g: --- → 1.3?
Flags: in-moztrap?(jhammink)
Priority: P3 → P1
Summary: [Messages][User Story] MMS to Email address → [User Story] MMS to Email address (FFOS 1.3)
(In reply to Gene Lian [:gene] from comment #12)
> (In reply to Rick Waldron from comment #11)
> > Is support already implemented in mozMobileMessage.sendMMS? Once that's
> > complete, this should be trivial.
> 
> Bug 866938 is under way to support. Gaia will be able to directly call
> sendMMS with e-mail addresses.

This is great news, thank you.
Assignee: nobody → waldron.rick
Summary: [User Story] MMS to Email address (FFOS 1.3) → [User Story][Messages] Send to Email address (FFOS 1.3)
Whiteboard: [ucid:Comms31, 1.3:p1]

Comment 14

4 years ago
Change in-moztrap and start to work on test cases
Flags: in-moztrap?(jhammink) → in-moztrap?(pyang)

Comment 15

4 years ago
Considering to use email from contact, need ux input for this case.
need info? Ayman
Flags: needinfo?(aymanmaat)

Comment 16

4 years ago
(In reply to Paul Yang: pyang: pyang@mozilla.com from comment #15)
> Considering to use email from contact, need ux input for this case.
> need info? Ayman

Hey Paul, happy to give you input, can you give me more detail on the input you would like.

Thanks
Flags: needinfo?(aymanmaat) → needinfo?(pyang)

Comment 17

4 years ago
Hi Ayman,
just want to make sure if we cover these cases:
- email matches an existing contact, should we covert it to a contact's name? If so, that should be different from phone number
- Contact suggestion works for email as well.
- In contact app, can user choose to send message to one's email?
Flags: needinfo?(pyang)

Updated

4 years ago
Flags: needinfo?(aymanmaat)
Duplicate of this bug: 866938
1.3+ committed feature
blocking-b2g: 1.3? → 1.3+

Comment 20

4 years ago
(In reply to Paul Yang [: pyang] from comment #17)
> Hi Ayman,
> just want to make sure if we cover these cases:
> - email matches an existing contact, should we covert it to a contact's name? If so, that should be different from phone number

We should maintain the same behaviour as is currently on the phone with regards to phone number.


> - Contact suggestion works for email as well.

Yes please. we need to include email addresses in the auto suggestions

> - In contact app, can user choose to send message to one's email?

…this is something i am trying to clarify now, will get back to you on this


leaving ni? to me
(In reply to ayman maat :maat from comment #20)
> (In reply to Paul Yang [: pyang] from comment #17)
> > Hi Ayman,
> > just want to make sure if we cover these cases:
> > - email matches an existing contact, should we covert it to a contact's name? If so, that should be different from phone number
> 
> We should maintain the same behaviour as is currently on the phone with
> regards to phone number.
> 
> 
> > - Contact suggestion works for email as well.
> 
> Yes please. we need to include email addresses in the auto suggestions
> 
> > - In contact app, can user choose to send message to one's email?
> 
> …this is something i am trying to clarify now, will get back to you on this
> 
> 
> leaving ni? to me

Just want to confirm the first two above. The third will require some effort from Contacts app, but will be no problem for Messages app

Comment 22

4 years ago
(In reply to ayman maat :maat from comment #20)
> (In reply to Paul Yang [: pyang] from comment #17)
> > Hi Ayman,
> > just want to make sure if we cover these cases:
> >
> > - In contact app, can user choose to send message to one's email?
> 
> ...this is something i am trying to clarify now, will get back to you on this

I have confirmation that we will not be doing this for V1.3
Flags: needinfo?(aymanmaat)
(In reply to ayman maat :maat from comment #22)
> (In reply to ayman maat :maat from comment #20)
> > (In reply to Paul Yang [: pyang] from comment #17)
> > > Hi Ayman,
> > > just want to make sure if we cover these cases:
> > >
> > > - In contact app, can user choose to send message to one's email?
> > 
> > ...this is something i am trying to clarify now, will get back to you on this
> 
> I have confirmation that we will not be doing this for V1.3

That's a bummer! Is this moving on to 1.4?
No longer blocks: 917190
blocking-b2g: 1.3+ → ---
Priority: P1 → --
Whiteboard: [ucid:Comms31, 1.3:p1]
Blocks: 917190
blocking-b2g: --- → 1.3+
Priority: -- → P1
Whiteboard: [ucid:Comms31, 1.3:p1]
Wilfred, 

It just occurred to me that Ayman's comment was only regarding that _one_ very specific case. Apologies for removing the tags.
Blocks: 920625
No longer blocks: 917190
blocking-b2g: 1.3+ → ---
Whiteboard: [ucid:Comms31, 1.3:p1] → [ucid:Comms31, 1.3:p2]
Whiteboard: [ucid:Comms31, 1.3:p2] → [ucid:Comms31, 1.3:p2, ft:comms]
Checked in twice on https://bugzilla.mozilla.org/show_bug.cgi?id=866938, no answer to first (11/15)
Blocks: 945644
No longer blocks: 920625
Severity: blocker → normal
Not this is required by partner for Madai.
(In reply to Wayne Chang [:wchang] from comment #26)
> Not this is required by partner for Madai.

That was supposed to read "Note this is required by partner for Madai."
Duplicate of this bug: 959086

Updated

4 years ago
Blocks: 956203
Duplicate of this bug: 961955

Updated

4 years ago
Blocks: 891754
Rick, are you still working in this feature?
Flags: needinfo?(waldron.rick)
(In reply to Beatriz Rodríguez [:brg] from comment #30)
> Rick, are you still working in this feature?

That was my plan, but there is nothing I (or anyone) can do until https://bugzilla.mozilla.org/show_bug.cgi?id=866938 is resolved.
Flags: needinfo?(waldron.rick)
Editing the tittle trying to be more precisse.
Summary: [User Story][Messages] Send to Email address (FFOS 1.3) → [User Story][Messages] Send to Email address (FxOS 1.4)
(In reply to Beatriz Rodríguez [:brg] from comment #32)
> Editing the tittle trying to be more precisse.

Pinged that other ticket https://bugzilla.mozilla.org/show_bug.cgi?id=866938#c27
Blocks: 971599

Updated

4 years ago
Blocks: 974333

Updated

4 years ago
No longer blocks: 971599

Updated

4 years ago
blocking-b2g: --- → 1.4?
Triage: new feature so adding it to backlog
blocking-b2g: 1.4? → backlog
This is high priority feature from partner. Propose to be included in 1.5.
Summary: [User Story][Messages] Send to Email address (FxOS 1.4) → [User Story][Messages] Send to Email address (FxOS 1.5)
Whiteboard: [ucid:Comms31, 1.3:p2, ft:comms] → [ucid:Comms31, 1.5, ft:comms]
blocking-b2g: backlog → 1.5?
this is part of the partner contribution for madai

ni? cawang / omega for UX
blocking-b2g: 1.5? → madai?
Flags: needinfo?(ofeng)
Flags: needinfo?(cawang)
Created attachment 8394746 [details]
[1.5 Messages] Send MMS to Email v1.0.pdf

Please see the UX spec for details.
Flags: needinfo?(ofeng)

Updated

4 years ago
Whiteboard: [ucid:Comms31, 1.5, ft:comms] → [ucid:Comms31, 1.5, ft:comms] [m+]
Hi Vicky, please help on the visual design, thanks!
Flags: needinfo?(vpg)
Created attachment 8399978 [details]
Visual Mockup. Compose emailindicator hitstate
Flags: needinfo?(vpg)
Created attachment 8399980 [details]
Visual Mockup. Compose email indicator
Created attachment 8399982 [details]
Visual Spec. Compose email indicator
Attached Visual material, both mockups and specs to implement what's requiered in this bug. The asset for the envelope icon is to come.
Created attachment 8399993 [details]
Asset. Email indicator icon for recipients bubbles.
retiring madai flag
For mozilla we should have this by 1.5

tracking for madai with m+
blocking-b2g: madai? → 1.5?

Updated

4 years ago
Depends on: 991094
triage: this is a feature for madai.
not plusing on a feature
blocking-b2g: 1.5? → backlog
Created attachment 8404006 [details]
[MADAI][Contact] Send to email address.pdf

Hey guys, for this feature, we need to add a message button in Contact details. I've uploaded the spec here. Please take a look. :)
For the visual design, I think we can adopt the same message button which is used for phone numbers. ni? Vicky to confirm it. Thanks!
Flags: needinfo?(cawang) → needinfo?(vpg)
(In reply to Carrie Wang [:carrie] from comment #46)
> Created attachment 8404006 [details]
> [MADAI][Contact] Send to email address.pdf
> 
> Hey guys, for this feature, we need to add a message button in Contact
> details. I've uploaded the spec here. Please take a look. :)
> For the visual design, I think we can adopt the same message button which is
> used for phone numbers. ni? Vicky to confirm it. Thanks!

For the sake of consistency it hsould be just as it is with the numbers, so yes, agreeing woth you Carrie.

Thanks!
Flags: needinfo?(vpg)
Created attachment 8405272 [details]
[MADAI][Contact] Send to email address v2.0.pdf

Hi I've found a mistake on flow title and uploaded a revised version here. Not a big deal. The flow is still the same. Thanks!
Attachment #8394746 - Attachment is obsolete: true
Whiteboard: [ucid:Comms31, 1.5, ft:comms] [m+] → [ucid:Comms31, ft:comms] [m+][priority]
Duplicate of this bug: 996399
Flags: in-moztrap?(pyang) → in-moztrap?(ashiue)

Updated

4 years ago
Blocks: 984715

Updated

4 years ago
No longer blocks: 945644
Hi Rick,

Bug 866938 has been already landed, are you still planning to work on this?. Thanks!
Flags: needinfo?(waldron.rick)
Rick has no time to work on this now, so removing NI and assignee.

Noemi, you must know that some work is already happening in bug 974867.
Assignee: waldron.rick → nobody
Flags: needinfo?(waldron.rick)

Updated

4 years ago
Depends on: 974867

Updated

4 years ago
No longer blocks: 984715
Depends on: 974878, 982029

Updated

4 years ago
Depends on: 1014511
Depends on: 1026384
Alias: mms-by-email
Depends on: 1030672
Duplicate of this bug: 1034789
Depends on: 1039531
Assignee: nobody → salva
Salva, is there a reason you assigned yourself on this bug? This is mostly a meta bug :)
Assignee: salva → nobody
(In reply to Julien Wajsberg [:julienw] from comment #53)
> Salva, is there a reason you assigned yourself on this bug? This is mostly a
> meta bug :)

You are right, :)

One thing, Julien, I asked Salva to talk to you about this feature so he can help with the development as it's taking longer and it's an important certification waiver.

As you know the feature status better that us, let us know where are the best candidate bugs to start working on. Thanks!!
Flags: needinfo?(felash)
I knew it. I was assigning to me as reminder. I'm gonna review the bug's blockers, ask for some permissions and ask to you, Julien, of course. ;)
The main thing that's left to enable the feature is the blocking bug 1026384. Bug 997547 and bug 1030672 are nice to have (I think).

The blocking bug is already being worked on by a partner currently; it's really no big deal, but the partner takes some time to do it. You can discuss with him if you want to take over the bug.

Bug 997547 is awaiting a review from Francisco.
Bug 1030672: we need to assess if it's needed.
There are other dependencies in the restricted bug 974874, but they are mostly nice to have.
Depends on: 997547
Flags: needinfo?(felash)
Hubert, can I please access bug 1071495 ?
Flags: needinfo?(hlu)
See Also: bug 1071495
Hi Julien,
   Add you in cc list. Pleas check it.
Flags: needinfo?(hlu)
Hubert, I'm still unauthorized to access the bug. Maybe it's not important, but because you added it here I thought it could be useful that I have access to it.
Flags: needinfo?(hlu)
Hi Julien,
    Has confirmed that your email account is added in bug 1071495 cc list. Please try to access it again. Thank you.
Flags: needinfo?(hlu)
Depends on: 1079255
Depends on: 1079257

Comment 61

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: backlog → 2.0?
Hi Julien, I'm trying to digest the history of comments and my understanding in short is, this feature is completed already in FFOS 1.5 after bug 1026384 is done (based on comment#56), right? (Not considering other nice to have bugs like Bug 997547 and bug 1030672)

Thanks in advance.
Flags: needinfo?(felash)
no dont think this is done - MMS to email address is still pending between madai and other partner interest to complete the work.

Comment 64

3 years ago
(In reply to 田旻 from comment #61)
> [Blocking Requested - why for this release]:

Dears, 

Can this bug be fixed on v2.0?

BRs,
TIAN Min
I dont think this feature will happen in 2.0 - I also dont think it will happen in 2.1. The best possible solution is this happening in 2.2.
Thanks Wilfred! We hope so :)
Summary: [User Story][Messages] Send to Email address (FxOS 1.5) → [User Story][Messages] Send to Email address (FxOS 2.2)
before we say this is planned for 2.2 - I want to make sure we understand that there are a lot of IFs and BUTs. so lets not take what i said above as that we are mandating this is coming in 2.2.

But there is a good chance for us to bring this into 2.2 if there is the right amount of contribution and testing.
Thanks Wilfred's information sharing! Then at least it's clear we won't fix it in 2.0 & 2.1, so plan to de-nominate it from 2.0 in coming Triage.
All bugs except bug 1079257 are necessary. They're all quite small and easy to do, except bug 1078384 that needs some CSS change and where we haven't completely finished to settle on a spec.

It's all a matter of focussing. Right now the priority is not on this feature so we don't move quickly on this. The work is done by partners and it looks like that even partners are busy on other things.
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #69)
> It's all a matter of focussing. Right now the priority is not on this
> feature so we don't move quickly on this. The work is done by partners and
> it looks like that even partners are busy on other things

Salva will continue working on them next week (this week is on PTO) if no more Cost Control issues raise.
Thanks for Julien and Maria's information! So in short we can say "targeting 2.2" but clear that won't fix it in 2.0/2.1. Still a de-nominate candidate in coming 2.0 Triage.
(In reply to Wesly Huang from comment #71)
> Thanks for Julien and Maria's information! So in short we can say "targeting
> 2.2" but clear that won't fix it in 2.0/2.1. Still a de-nominate candidate
> in coming 2.0 Triage.

agreed, unfortunately, too late for those versions
[Triage] by 2.0 design.
blocking-b2g: 2.0? → -
Duplicate of this bug: 1090671
Depends on: 1090945
Flags: in-moztrap?(ashiue) → in-moztrap?(echang)
blocking-b2g: - → backlog
tracking-b2g: --- → +
Depends on: 1135649
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
[Tracking Requested - why for this release]:
tracking-b2g: + → backlog
Flags: in-moztrap?(echang) → in-moztrap?(hcheng)
Flags: in-moztrap?(hcheng) → in-moztrap?(gchang)
This is now mostly working. 2 bugs are left, but that do not impair the functionality, so I'm closing this meta bug now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 934077
Duplicate of this bug: 959001
You need to log in before you can comment on or make changes to this bug.