bankofamerica.com - Bank of America recommends that you not use N6 for online banking

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P1
normal
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Kevin McCluskey (gone), Assigned: Arun Ranganathan)

Tracking

Details

(Whiteboard: bugscape 5084 [USERAGENT][DENY], URL)

(Reporter)

Description

17 years ago
If you go to Bank of America to learn more about their online banking they
explicitly recommend that you do not use N6. They do not give an explanation why
however.

Comment 1

17 years ago
this is a dup.
Whiteboard: dupeme

Comment 2

17 years ago
*** Bug 85455 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Whiteboard: dupeme → [BANKING][USERAGENT][DENY]

Updated

17 years ago
Priority: -- → P1

Updated

17 years ago
Summary: Bank of America recommends that you not use N6 for online banking → bankofamerica.com - Bank of America recommends that you not use N6 for online banking

Comment 3

17 years ago
see http://bugscape.mcom.com/show_bug.cgi?id=5084
Status: NEW → ASSIGNED

Comment 4

17 years ago
Looks fixed to me. -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
uhh, not for me. i still get a javascript popup that says i should be using
netscape 4.x instead... 

Comment 6

17 years ago
ok, -> reopen
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

17 years ago
I think this may depend on what state you are in.  I'm in Texas and I get the
"Netscape 6 is bad" message.

Comment 8

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 9

17 years ago
-> Arun
Assignee: bclary → aruner
Status: REOPENED → NEW

Comment 11

17 years ago
evang bugs belong in bugscape, please see bugscape bug 5084
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX

Comment 12

17 years ago
*** Bug 105938 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
The bug can be in bugscape, but it also has to be open here so that 
people wont file dups and those outside of netscape (yes, we really do 
exist) can have some idea what is going on with this issue. Reopening. 
Please add all bugscape bug numbers to the status whiteboard but keep 
the bug open until the 'scape bug is closed.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Whiteboard: [BANKING][USERAGENT][DENY] → bugscape 5084 [BANKING][USERAGENT][DENY]

Comment 14

16 years ago
Worse yet, the BofA site now actually *prevents* access to their online banking
if it detects Mozilla.  Previously, they only warned you.
I can confirm that BofA's online banking has been blocking Mozilla and Netscape
6.x ( the page that is shown identifies Mozilla or Netscape 6.x as "Netscape 6",
and claims that "Netscape 6 is not supported" ) for the California site.

I sent them a note asking for an ETA, and offering assistance if it was
required. This was about 4 days ago, no response yet. I tried faking the
useragent string and going in to look for problems, didn't notice any but it
wasn't exactly an exhaustive QA session. Transfering funds and looking at
transaction history worked as expected.

Comment 16

16 years ago
In fact, I had no problems using the BofA site at all before they blocked access.
I just logged in to my BofA account with the latest Mozilla build on Solaris 7 
( build id - 2001120522 ), and they are not blocking or giving me warnings of
any kind.

If they are also letting NS6 in at this point, this bug should be closed.

Comment 18

16 years ago
it's about damn time... i can confirm that this now works with mozilla. 
I received this email after inquiring why they called Netscape 6 a "beta
browser" in a previous email ( I asked them to detail what problems they are
seeing ) :

---

Thank you for your inquiry. Netscape 6.1 has been tested with Online
Banking and a number of problems have occurred. For example, icons
appear and disappear from the system. Therefore, at the present time,
Online Banking does not support the use of the Netscape 6.1 browser.
However, we are working aggressively to resolve this problem and restore
full service. Please accept our apologies for any inconveniences
experienced by this problem.  To access Online Banking until the problem
is resolved, please select one of the following browser alternatives:
 
        For IBM compatible users
        Netscape Navigator 4.x
        Netscape Communicator 4.x
        Microsoft Internet Explorer 4.x
        Microsoft Internet Explorer 5.x
        For Macintosh users
        Netscape Navigator 4.x
        Netscape Communicator 4.x
        Microsoft Internet Explorer 4.x
        Microsoft Internet Explorer 5.x
 
You may need to visit the web site of Netscape or Microsoft Internet
Explorer to download the browser.  Again, we apologize for the
inconvenience.
 
If we may be of further assistance, please contact us by e-mail or by
phone at 1.800.933.6262.
 
Kristyl Williams,
Online Banking
Component: US General → US Banks
QA Contact: zach → bclary
Whiteboard: bugscape 5084 [BANKING][USERAGENT][DENY] → bugscape 5084 [USERAGENT][DENY]

Updated

16 years ago
Keywords: evang500
(Assignee)

Comment 20

16 years ago
Frankly, we're almost there.  Expect to see something different w.r.t BofA
experience by February 9 '02 (tentative ETA given to me by head of Internet
Banking).
Until then, hang tight :-)

Comment 21

16 years ago
Aruner, what is there to do on this now?  I just tried the BofA site using
Mozilla, and everything seems to work fine already.  In fact, it's been working
since early December.
(Assignee)

Comment 22

16 years ago
Warner,

The remaining issues are:
1. Netscape 6.x is still blocked, but not Mozilla.  The problem here is that I
suspect Mozilla is *not* blocked because of a faulty user-agent sniff that
doesn't really reflect an "unblocking" but rather an act of ignorance :-)

2. Messaging ought to change to reflect that Netscape 6 is welcome again.  By
this I mean, I'm encouraging BofA to put something up to the effect that
"Netscape 6 welcome again!"

Comment 23

16 years ago
Arun, possibly BofA just has bad user-agent sniffing code.  However, they *did*
block Mozilla (as opposed to Netscape 6) at one point, and obviously that's
changed.  I just didn't realize NS 6 was still being blocked.
(Assignee)

Comment 24

16 years ago
I'm marking this FIXED
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 25

16 years ago
Verified
2002022703/WinXP
Status: RESOLVED → VERIFIED

Comment 26

15 years ago
Moving to new component
Component: US Banks → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.