"general.useragent.locale" parameter in Firefox linux l10n builds is "en-US"

RESOLVED FIXED in mozilla21

Status

Firefox Build System
General
RESOLVED FIXED
5 years ago
4 months ago

People

(Reporter: Alexander L. Slovesnik, Assigned: glandium)

Tracking

unspecified
mozilla21
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1) Download http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/firefox-21.0a1.de.linux-i686.tar.bz2
2) Open about:config

Expected results: Value of "general.useragent.locale" is "de"

Actual results: Value of "general.useragent.locale" is "en-US".
Possibly fallout from bug 755724?
Depends on: 755724
PS: confirmed on my german mac nightly.
(Assignee)

Comment 3

5 years ago
Likely a problem in l10n-repack.
Assignee: nobody → mh+mozilla
There's no defaults/preferences/firefox-l10n.js in omni.ja, compared to release.
(Assignee)

Comment 5

5 years ago
(In reply to Axel Hecht [:Pike] from comment #4)
> There's no defaults/preferences/firefox-l10n.js in omni.ja, compared to
> release.

It's now in browser/omni.ja, but it has the en-US content. The langpack should work, though.
(Assignee)

Comment 6

5 years ago
Searchplugins are also affected.
(Assignee)

Comment 7

5 years ago
Created attachment 713025 [details] [diff] [review]
Search for l10n files in all app bases during l10n-repack

The fix is fortunately straightforward.
Attachment #713025 - Flags: review?(gps)

Updated

5 years ago
Blocks: 840996
This likely also affects default bookmarks (See bug 840996)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 840996
Comment on attachment 713025 [details] [diff] [review]
Search for l10n files in all app bases during l10n-repack

Review of attachment 713025 [details] [diff] [review]:
-----------------------------------------------------------------

I'll keep saying we need tests for l10n-repack.py until we have them :)

Don't let that prevent checkin.
Attachment #713025 - Flags: review?(gps) → review+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/mozilla-central/rev/c73747cd5eba
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.