Firefox v18.0.2 Lockups When Closing Page

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: tecknode, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

Closing my blog page http://magesoapbox.blogspot.com/


Actual results:

Closing my blog page often causes Firefox v18 to lockup, have to use Task Manager to close.  Note this was NOT a problem in older versions.


Expected results:

Clicking [X] on a tab should closed it without lockup.
(Reporter)

Comment 1

6 years ago
Just noticed; when I click [X] to close the tab with my blog AND there's NO lock-up, the tab window goes blank then takes some time to disappear and there's hard-drive action until it closes.

Comment 2

6 years ago
Confirming poor performance on provided page on trunk, profiling data:
http://people.mozilla.com/~bgirard/cleopatra/#report=ba2ac9a8b3826ccd3b297ebaba7ff4ceab0e6eb2
53% of time spended in appendError() @ consoleBindings.xml:229
Status: UNCONFIRMED → NEW
Component: Untriaged → Error Console
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Toolkit
Hardware: x86 → All
Version: 18 Branch → Trunk

Comment 3

6 years ago
Possible dups:
Bug 796179 - Errors in files with large data URIs can cause the error console to consume gigabytes of memory and lock up the browser
Bug 831020 - Errors in the error console with very long reference lines hang the browser 
Bug 840451 - Browser stop to response for a while if Error console is staying open
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.