Bringing up bookmarks menus crashes browser

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
--
critical
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Matthew Cline, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build 2001060408, Linux 2.4.5 i686, RedHat 6.1, XFree86 4.0.1

Bringing up the bookmarks menu, either with the mouse or with the Alt+B
keystrokes, caused Mozilla to crash.  This also happened with new profiles
(although you might have to exit and restart Mozilla on the new profile
to get the crash).  The stack trace for the crash always looks like:

#0  0x4127c1fb in GetInsertionPoint ()
   from /usr/home/matt/graze/browsers/mz/components/libgklayout.so
#1  0x4127c2b8 in nsMenuBarFrame::FindMenuWithShortcut ()
   from /usr/home/matt/graze/browsers/mz/components/libgklayout.so
#2  0x4127c5ca in nsMenuBarFrame::ShortcutNavigation ()
   from /usr/home/matt/graze/browsers/mz/components/libgklayout.so
#3  0x4127dce5 in nsMenuBarListener::KeyPress ()
   from /usr/home/matt/graze/browsers/mz/components/libgklayout.so
#4  0x40c77109 in nsEventListenerManager::HandleEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#5  0x40d67e0c in nsXULDocument::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#6  0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#7  0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#8  0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#9  0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#10 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#11 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#12 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#13 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#14 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#15 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#16 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#17 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#18 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#19 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#20 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#21 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#22 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#23 0x40d55c70 in nsXULElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#24 0x40dda5e3 in nsGenericElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#25 0x40cb25b7 in nsHTMLInputElement::HandleDOMEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkcontent.so
#26 0x411c5db7 in PresShell::HandleEventInternal ()
   from /usr/home/matt/graze/browsers/mz/components/libgklayout.so
#27 0x411c5c43 in PresShell::HandleEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgklayout.so
#28 0x41301806 in nsView::HandleEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkview.so
#29 0x4130ae8e in nsViewManager::DispatchEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkview.so
#30 0x413011ad in HandleEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libgkview.so
#31 0x407aee0a in nsWidget::DispatchEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libwidget_gtk.so
#32 0x407aed35 in nsWidget::DispatchWindowEvent ()
   from /usr/home/matt/graze/browsers/mz/components/libwidget_gtk.so
#33 0x407ad371 in nsWidget::OnInput ()
   from /usr/home/matt/graze/browsers/mz/components/libwidget_gtk.so
#34 0x407a990f in handle_key_press_event ()
   from /usr/home/matt/graze/browsers/mz/components/libwidget_gtk.so
#35 0x407a9def in dispatch_superwin_event ()
   from /usr/home/matt/graze/browsers/mz/components/libwidget_gtk.so
#36 0x407a9b5c in handle_gdk_event ()
   from /usr/home/matt/graze/browsers/mz/components/libwidget_gtk.so
#37 0x40359d60 in gdk_event_free () from /usr/lib/libgdk-1.2.so.0
#38 0x4038eec1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#39 0x4038f08c in g_main_run () from /usr/lib/libglib-1.2.so.0

Comment 1

17 years ago
GetInsertionPoint() sounds like bug 83974, which was apparently fallout of bug 
80512.  That's been fixed (again); hopefully this will go away.
(Reporter)

Comment 2

17 years ago
Bug 80512 has been fixed, and so has this one, with build 2001060421

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.