All users were logged out of Bugzilla on October 13th, 2018

Reproducible crash in gfxContext::gfxContext

RESOLVED FIXED in mozilla21

Status

()

--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

({crash, regression})

2.0 Branch
mozilla21
x86
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-396c999f-a64c-45d6-94a9-149df2130213 .
============================================================= 

I think this is an OOM crash but I'm sure. We're crashing on a null de-reference. My process is at about 1.5GB of RAM so we shouldn't be failing an allocation on a 64-bit mac build with 16GB of memory (8GB free).

Hosting the file since it's 18MB:
https://dl.dropbox.com/u/10523664/galaxymapgl-OOM.tar.gz

STR:
1) Open index.html, select all the stars
2) Wait for the stars to loads
3) Typically I get a crash before all the stars load but sometimes I have to reload a few times
(Assignee)

Comment 1

6 years ago
Caused by bug 593733, we don't check if the allocation succeeded or not:
http://hg.mozilla.org/mozilla-central/annotate/36525224b14e/gfx/layers/opengl/ThebesLayerOGL.cpp#l734
Depends on: 593733
(Assignee)

Comment 2

6 years ago
Created attachment 713261 [details] [diff] [review]
patch

This restores the behavior before your patch landed.
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #713261 - Flags: review?(matt.woodrow)
Attachment #713261 - Flags: review?(matt.woodrow) → review+
(Assignee)

Comment 3

6 years ago
(In reply to Benoit Girard (:BenWa) from comment #0)
> I think this is an OOM crash but I'm sure. We're crashing on a null
> de-reference. My process is at about 1.5GB of RAM so we shouldn't be failing
> an allocation on a 64-bit mac build with 16GB of memory (8GB free).
> 

I had my build running in 32-bit mode so that explains why I was running out of memory so fast.

Updated

6 years ago
Blocks: 593733
No longer depends on: 593733
Keywords: regression
Version: Trunk → 2.0 Branch
https://hg.mozilla.org/mozilla-central/rev/e6ca584f4fe7
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.