Closed Bug 84093 Opened 20 years ago Closed 18 years ago

hangs on java, RedHat 7.1

Categories

(Core Graveyard :: Java: OJI, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME
Future

People

(Reporter: baron, Assigned: joshua.xia)

References

()

Details

(Keywords: relnote, Whiteboard: [oji_working])

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9) Gecko/20010505
BuildID:    2001060411

When Java is enabled, the page hangs.  If I turn
off Java, it works.  This 

Reproducible: Always
Steps to Reproduce:
1.go to page with Java enabled

Actual Results:  hangs

Expected Results:  loads

Java installation came from http://mozilla.org/releases/
Dupe of bug 84030?
WORKSFORME with Monday's linux trunk built debug enabled on RH7.0 linux with 
JDK1.3.1.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
I was also using Monday's build, as I specified in my report.  I used
the version of Java from the Mozilla release notes page, however, which
may not be the same as JDK 1.3.1.  I am using RH Linux 7.1.
Jon
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Worksforme on RH 7.0 with JDK1.3.0_01 and JDK1.3.1.  The former ships with 
Netscape 6.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Reopening again.  It's clear that the problem is on some machines and not others.  
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've posted for help in reproducing this on n.p.m.java:

Newsgroups: netscape.public.mozilla.java
Subject: Please help: reproduce this bug: 84093
Date: 06 Jun 2001 13:10:07 -0700
Message-ID: <7cb3d9dcqu8.fsf@sun.com>

I'm reluctantly accepting, just to get this off my NEW list.
Status: NEW → ASSIGNED
Whiteboard: [oji_working]
on linux branch 0605, it takes a lot of time (10-15 seconds) for this page to 
laod up after I click on the test url. That makes a user think that the browser 
is frozen.   
Perhaps I am impatient.  I just tried it again with Build ID
2001060600, and I gave up after 3 minutes.  The stop button did
not work.  Again, this is with RH Linux 7.1, on a 500 mhz computer.
I am having the exact same problem.  RH 7.1 on a SMP box.  Using the java plugin
that the browser directs me to use.  On previous builds I was able to use java
without problem, but I don't know when the problem started.

The Java I'm trying is the link to the IBM realtime scoreboard in the upper
right area of the page at http://frenchopen.org/en

From the cmdline terminal; hangs (killed after 5 minutes) after last line of
output.  No CPU utilization after hang.

[mike@ci mozilla]$ ./mozilla
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/home/mike/mozilla
 
LD_LIBRARY_PATH=/home/mike/mozilla:/home/mike/mozilla/plugins:/usr/X11R6/lib:/usr/X11R6/lib/modules
     LIBRARY_PATH=/home/mike/mozilla:/home/mike/mozilla/components
       SHLIB_PATH=/home/mike/mozilla
          LIBPATH=/home/mike/mozilla
       ADDON_PATH=/home/mike/mozilla
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Registering plugin 0 for: "*","All types",".*"
Registering plugin 0 for: "application/x-java-vm","Java(tm) Plug-in",""
Registering plugin 1 for: "application/x-java-applet","Java(tm) Plug-in",""
Registering plugin 2 for: "application/x-java-applet;version=1.1","Java(tm)
Plug-in",""
Registering plugin 3 for: "application/x-java-applet;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 4 for: "application/x-java-applet;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 5 for: "application/x-java-applet;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 6 for: "application/x-java-applet;version=1.2","Java(tm)
Plug-in",""
Registering plugin 7 for: "application/x-java-applet;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 8 for: "application/x-java-applet;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 9 for: "application/x-java-applet;version=1.3","Java(tm)
Plug-in",""
Registering plugin 10 for:
"application/x-java-applet;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Registering plugin 11 for: "application/x-java-bean","Java(tm) Plug-in",""
Registering plugin 12 for: "application/x-java-bean;version=1.1","Java(tm)
Plug-in",""
Registering plugin 13 for: "application/x-java-bean;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 14 for: "application/x-java-bean;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 15 for: "application/x-java-bean;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 16 for: "application/x-java-bean;version=1.2","Java(tm)
Plug-in",""
Registering plugin 17 for: "application/x-java-bean;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 18 for: "application/x-java-bean;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 19 for: "application/x-java-bean;version=1.3","Java(tm)
Plug-in",""
Registering plugin 20 for:
"application/x-java-bean;jpi-version=1.3.0_01","Java(tm) Plug-in",""
imap://mike@twinpeaks.prc.com/INBOX
imap://mike@twinpeaks.prc.com...skipping, already opened
mailCharsetLoadListener: ISO-8859-1 

Error loading URL javascript:launch() : 2152924149
I get exactly the same problem with 0.9.1 on a Red Hat 7.1 box
running 2.4.5. 100% reproducible, causing a hang if you visit a
page with a Java applet with Java enabled. I got my JVM from
http://home.netscape.com/plugins/jvm.html as mentioned in the
release notes. about:plugins shows 21 MIME types registered for
the Java plugin. I can provide more info on request...
tethys, do you also have an SMP box?  Perhaps this problem is specific to an 
SMP machine config.
My dad's (baron@cattell.psych.upenn.edu, the original reporter) machine is not
an SMP box.
Nope, uniprocessor only, but I can duplicate it on several different
machines, running assorted kernels.
*** Bug 84787 has been marked as a duplicate of this bug. ***
*** Bug 85248 has been marked as a duplicate of this bug. ***
i see this on my redhat 7.1 machine, although my redhat 6.x machine handles java
just fine.
Xiaobin, can you please see if you can reproduce this bug on Linux?

Assignee: edburns → xiaobin.lu
Status: ASSIGNED → NEW
Reporter:
    I tried the page with latest trunk + jre 1.3.1 and it works fine in my
Redhat 6.1.
    Do you have problems with other java applet? You can test it by going to
java.sun.com.
In response to the last two comments by edburns and Xiaobin Lu,
let me call attention to the earlier comment by Joseph Elwell.
It seems likely that this bug is specific to RH 7.1.  It is still
a bug.  That is the current version of the most popular form of
Linux.  And, on the same computer, Netscape 4.7 does not have any
problems with Java.
Yes, I have this problem with *all* java applets, including java.sun.com
(on RH7.1).
my redhat 6.1 and 0613 trunk build stil lshows the delay (15-20 secs of 
freeze)and then the page loads fine. I would expect the page to load immediately 
after i enter the url
shrir:
   Yes, this is due to lazy loading fix. When you visit an applet page for the
first time, it is always slow.
are we going to fix this (lazy loading) thing or is it going to remain like 
this?
Lazy loading is a fix for the lazy start up of mozilla. So probably we will 
remain like this.
Again, let me point out that 3 minutes is not just "slow".
There may be two different problems here, or not.

What's OS are you running? For redhat 6.1 it is fast to run the applet.
Note: my redhat 6.1 takes a lot of time first time to load a page with applet 
(due to the lazy laoding thing..) . LAter on, things become faster and other 
applet pages load fine. http://frenchopen.org/en realtie scoreboard laods up 
jsut fine.  I do not have a 7.1 to see if this is a blocker on that :(
Confirmed that this is a Red Hat 7.1 specific problem. I installed
into an NFS mounted directory, available from both RH7.0 and RH7.1
machines. On 7.0, going to java.sun.com hung the browser for
perhaps 15-30 seconds before correctly displaying the applet
(i.e., painfully slow, but just about bearable). On RH7.1, it hung
the browser for over 10 minutes before I gave up and killed it.
Summary: hangs on java → hangs on java, RedHat 7.1
i think it's definetely a RedHat 7.1 specific problem,
as i'm having the same problem on my rh71 box
(PII 450 uniprocessor).
Since this is a RH7.1 specific problem, I just want to make sure
that everyone knows about this, which may be completely irrelevant:

http://www.redhat.com/support/manuals/RHL-7.1-Manual/release-notes/s1-known-issues.html

Specifically:

Some Java JVMs (both from Sun and IBM) don't work with the new floating stack
feature of the i686 version of glibc. The failures are due to programming
assumptions in the JVMs that are now invalid. JVM vendors are working on making
the necessary corrections. Until corrected JVM packages are available, you may
force glibc to use the deprecated stack model by setting the following
environment variable:

LD_ASSUME_KERNEL=2.2.5
Specifically:

>Some Java JVMs (both from Sun and IBM) don't work with the new floating stack
>feature of the i686 version of glibc. The failures are due to programming
>assumptions in the JVMs that are now invalid. JVM vendors are working on making
>the necessary corrections. Until corrected JVM packages are available, you may
>force glibc to use the deprecated stack model by setting the following
>environment variable:
>
>LD_ASSUME_KERNEL=2.2.5

Congratulations:
[jonny@dh3mb mozilla]$ export LD_ASSUME_KERNEL=2.2.5
[jonny@dh3mb mozilla]$ ./mozilla
=> Java works perfect...
well... at least mozilla loads java enabled pages now...

so i can finally delete ns4.7 now, thank you! :-)
so close this one now ?
i suggest someone puts this into the release notes
before closing the bug...
This is the same as 85041
*** Bug 85041 has been marked as a duplicate of this bug. ***
*** Bug 82968 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Future
What's sun doing about it? Will they fix the JDK any time soon?
*** Bug 87192 has been marked as a duplicate of this bug. ***
It's important that you only use the LD_ASSUME_KERNEL env variable with the old
version of the JVM.  1.3.1 and above seem to work fine with 2.4 and the newer
glibc.  I'm going to put a hack into the mozilla startup script for the rpms
that will try and tell what version of the jvm you have installed.
Why is the package that's autodownloaded jdk 1.3.0? Why hasnt anyone made a
jdk1.3.1 package? And why haven't I been told anywhere that I could just put a
symlink to the copy of the jdk that I already have installed?
Status: NEW → ASSIGNED
*** Bug 90467 has been marked as a duplicate of this bug. ***
tester: political reasons.
I though we had a nice Sun-AOL-Netscape alliance and that they lived in a world
a love...  Anyways... I hope that those political reasons can be fixed asap.

As a separate issue... the possibility to simlink the JDK outside of the moz
tree should be documentated too...
*** Bug 92181 has been marked as a duplicate of this bug. ***
*** Bug 92628 has been marked as a duplicate of this bug. ***
FYI: I'm using JDK 1.3.1 (Sun build24) and RH Linux 7.1 and still seeing this
problem... (above, C. Blizzard indicated that he felt this configuration might
work OK).
I'm using JDK 1.3.1 and RH 7.1 and it the bug has disapered when I installed the
jdk1.3.1....
*** Bug 93004 has been marked as a duplicate of this bug. ***
I can confirm that Mozilla 0.9.3 on RedHat 7.1 linux 2.4.5 with Sun JRE 1.3.1
JRE is still a problem. Even with or with out the export LD_ASSUME_KERNEL=2.2.5
loading a page that contains Java will crash mozilla. This is true with IBM's
most recent JRE 1.3_9 as well.
I downloaded JRE1.3.1 and Mozilla 0.9.3, it works pretty fine. We should push 
Netscape to ship JRE1.3.1 with Mozilla, I think.
I retract my previos comment. Sun JRE 1.3.1 does work with RH7.1
Yes, but you must still set LD_ASSUME_KERNEL=2.2.5. I tried 0.9.3 with JRE 1.3.1
without doing this and it crashed (someone had claimed that it might not
still be necessary). Put back the setting of the env vbl and
all was well again.

This is not true. I am running RedHat 7.1 linux 2.4.2-2 with mozilla 0.9.3 Sun
JRE 1.3.1 and I do not have the LD_ASSUME_KERNEL env var set. Mozilla and java
work for me. 
You mean it is not true *for you*.
I have just got mozilla 0.9.3 working with java (the default that it downloads
from netscape) and redhat 7.1.
I had to use LD_ASSUME_KERNEL=2.2.5 and also "ulimit -s 2000".
Perhaps this will help others who have been struggling with mozilla, java and
redhat 7.1 - so far if it works it works well, but it isn't 100% reliable (just
to warn you).
I just rebuilt from CVS (with co date 10 August 2001 10:38:03 PDT) and with
this build, I can use JRE 1.3.1 WITHOUT having to set LD_ASSUME_KERNEL. With
the talkback tarball 0.9.3 I was using before, I did need to set it. I have
RH 7.1 with the original kernel (2.4.2-2) and glibc (2.2.2-10) that came with
the distribution. I hope this turns out to be reproducible, but I am certainly
aware that different people have been getting different results on this issue.
SPAM: reassigning all OJI bugs to new OJI QA, pmac ( 227 bugs)
QA Contact: shrir → pmac
*** Bug 95274 has been marked as a duplicate of this bug. ***
I have RH7.1 updated with the latest kernel and glibc from updates.redhat.com. 
Mozilla 0.9.3 with Sun's JDK 1.3.1 freezes (I haven't tried the LD_ASSUME 
solution yet). The strange thing is that in J2SDK 1.3.1's Release Notes, they 
write:

"If you use Red Hat Linux 7, we recommend version 7.1 rather than 7.0. Limited 
testing has revealed problems when using J2SDK with Red Hat Linux 7.0, some of 
which are described below. 

The newer glibc-2.2.x libraries cannot correctly handle initial thread stack 
sizes larger than 6 MB. This can cause a segmentation fault on come Linux 
platforms that use the newer libraries. Such platforms include Red Hat 7.0, 
SuSe 7.2, and Debian 2.2. The problem will not occur on Linux platforms that 
are using glibc-2.1.x such as Red Hat 6.1 and 6.2. It will also not affect Red 
Hat 7.1 because it uses a different thread stack layout. This problem is being 
tracked as bug 4466587. "

I will try this LD_ASSUME_KERNEL and ulimit this night and report if it solves 
the problem for me. 
I tried the LD_ASSUME option with ulimit, the result is the same, still
freezing. There are 3 java applets on a page, they load just fine, but when I
click next page, it should go to a new html page, is supposed to close the open
applets, and open 3 new applets, but instead it stops working. I kill
mozilla-bin, then java_vm keeps running with 100 percent CPU use, then I can
kill it also.

kernel:

Linux version 2.4.3-12 (root@porky.devel.redhat.com) (gcc version 2.96 20000731
(Red Hat Linux 7.1 2.96-85)) #1 Fri Jun 8 15:05:56 EDT 2001

glibc:

glibc-common-2.2.2-10
glibc-devel-2.2.2-10
glibc-2.2.2-10
compat-glibc-6.2-2.1.3.2

WFM:  Running Moz from cvs (17-Aug 1739 PDT), RH 7.1 with shipping kernel
(2.4.2-2) and glibc (2.2.2-10), Sun Java 1.3.1-b24.  NO LD_ASSUME_KERNEL or
ulimit used.
I think I was the original reporter of this bug.  It works for me too with
the build of 08-17-15, with RH 7.1 as shipped (kernel 2.4.2-2, glibc
2.2.2-10) with Sun Java 1.3.1.

Now the trick is to make the installation easier and make sure it doesn't
regress.  For example, Sun's installation instructions for the RPM don't
tell you where you might find the file you need to link to - which
turns out to be /usr/java/jrel1.3.1/plugin/i386/ns600/.  (The /usr/java/
part was not stated explicitly.)  Jon Baron
Johnathan:
    Per your comment, I would like to close this bug. I requested long time ago 
to Netscape folks that they should put the JRe installation instruction to the 
rel notes. I don't the progress yet. Fortunately, we have several bugs opened 
for that. Please seach the bug assigned to asuk@eng.sun.com.

Xiaobin
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Verified on Linux, redhat 6.2 (commercial trunk: 2001-09-04-08-trunk)using JRE
version 1.3.0_01. It did not hang anymore. Marking verified.
Status: RESOLVED → VERIFIED
I don't see how verifying on Redhat 6.2 is valid since this only effects Redhat
7.1 (as per the Summary). I'm not going to reopen, but could we get another
verification?
Works OK in Redhat 7.1.
*** Bug 100792 has been marked as a duplicate of this bug. ***
*** Bug 105032 has been marked as a duplicate of this bug. ***
*** Bug 73916 has been marked as a duplicate of this bug. ***
I'm going to reopen this bug and re-resolve it as worksforme since nothing 
was actually fixed here. The only 'fix' here is the release note item. Items
in the release notes normally get deleted when their associated bugs are marked
fixed. Giving this bug a worksforme resolution will ensure the item doesn't
get accidently deleted.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
marking worksforme.
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → WORKSFORME
re-verifying
Status: RESOLVED → VERIFIED
*** Bug 100838 has been marked as a duplicate of this bug. ***
*** Bug 96988 has been marked as a duplicate of this bug. ***
*** Bug 105009 has been marked as a duplicate of this bug. ***
RedHat 7.2
All default packages.
Mozilla 0.9.7.
Java Plugin: Java(TM) Plug-in 1.3.0_01 (from autodownload)

----

**************** SERVER ERROR **************
CSecureJNI2_CallMethod: Bad parameters
**************** ************ **************
#
# HotSpot Virtual Machine Error, Unexpected Signal 11
# Please report this error at
# http://java.sun.com/cgi-bin/bugreport.cgi
#
# Error ID: 4F533F4C494E55580E43505005BC
#
# Problematic Thread: prio=1 tid=0x843d798 nid=0x928 runnable
#
INTERNAL ERROR on Browser End: Pipe closed during read? State may be corrupt
System error?:: Success
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
> Java Plugin: Java(TM) Plug-in 1.3.0_01 (from autodownload)

The solution to this bug was to use 1.3.1 rather than 1.3.0.  See comment 40. 
Is there a page that's still offering 1.3.0 for download?
Yes...
When you autodownload JRE from Mozilla, you'll take 1.3.0 version!
I've just downloaded from SUN site the 1.3.1 version... but I've not already 
installed and tested it.

Luca
WFM with 1.3.1 plugin. Note that the Sun download page for the 1.3.1
plugin is *woefully* under-documented. Furthermore, what documentation
that exists is inaccurate. It claims the plugin won't work without
changes to web pages to remove <applet> tags and replace them with
<object> or <embed> tags. This is demonstrably not true, as applets
continue to work fine with the <applet> tag.

Note that I'm also sta130@astradyne.co.uk, but bugilla is refusing to
let me log in as that user...
Jonathan Baron, can you try again to see the problem still exists since this bug 
hangs on linux rehdat 7.1. My machine is only redhat 6.2. Thanks!
It's certainly still happening for me on RH 7.1, using 0.9.7.

And also, as a side note, "LD_ASSUME_KERNEL" no longer seems to be working for
me, either.  If I add the hack to my /usr/local/mozilla/mozilla script, it no
longer keeps the client from locking up.

Blocks: 113957
This is also 100% reproducible for me - java pages hang when enabled.
(both Galeon & virgin Mozilla)
RedHat 7.2 with all RedHat & Ximian updates
Duron 900 processor
glibc-2.2.4-19.3.i686
- I tried to downgrade to the i386 version, but this gave me more problems
kernel-2.4.9-31.i686
- have tried LD_ASSUME_KERNEL=2.2.5 to no avail
jre-1.3.1-fcs
mozilla-0.9.8-1.ximian.4
galeon-1.0.3-1.ximian.2

My UserAgent does start Mozilla/5

Anything else I can try?
(I'm fairly sure that this used to work for me at one stage with RedHat 7.2..)

Thanks!
It looks like when I use symlink to Java plugin, it works, and hangs only when I
copy the .so file directly to $mozilla_home/plugins. Red Hat 7.2, JDK 1.4.0.
Hope this will help.
Yay - symlink to real file fixed it :)
Thx a mill...

cd /usr/lib/mozilla/plugins
rm libjavaplugin_oji.so
ln -s /usr/java/jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so
I am having a somewhat familiar problem except that java isnt detected by
mozilla.  Check out bug #155849.
I downloaded the JRE 1.4.1 RC from SUN, with Mozilla build 2002082122 and when I
load the java page, Java crashes, and Mozilla goes with it.

AMD Duron 800MHz 
320MB Ram
RH 7.0
Glibc 2.2-12
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: xiaobin.lu → petersen
Status: REOPENED → NEW
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen
This bug can't reproduce on the following environment:
  Redhat 7.2, mozilla 1.0.1, jre1.4.0_03 and jre1.4.1_01 
  Redhat 8.0, mozilla 1.1, jre1.4.0_03 and jre1.4.0_02 
There are no hang and no error and get the result from java console:
Default TimeZone = GMT+08:00
GMT+08:00 In Daylight = false
GMT+08:00 Uses Daylight = false
GMT In Daylight = false
GMT Uses Daylight = false
Loading image 1
Loading image 2
Loading image 3
Loading image 4
Loading image 3
reassign to me
Assignee: joe.chou → joshua.xia
WFM on Linux(RH8.0) mozilla1.2.1 JRE1.4.1_01
Status: NEW → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.