Can't arrange external apps position by customize.json

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: yurenju, Assigned: crdlc)

Tracking

({verifyme})

unspecified
ARM
Gonk (Firefox OS)
verifyme
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: QARegressExclude)

Attachments

(2 attachments)

Created attachment 713409 [details]
customize.json

STR:
1. create customize.json and put it to gaia root folder (reference attachment)
2. make production

expected:
1st app on page 1 is Marketplace

actually:
1st app on page 1 is Camera

I tried to put another app (like gallery) to 1st and it works except apps in external-apps.
(Assignee)

Comment 1

6 years ago
I am going to take a look, thanks
(Assignee)

Comment 2

6 years ago
I can reproduce it, external apps cannot be arranged
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 3

6 years ago
Created attachment 713442 [details]
Patch v1
Attachment #713442 - Flags: review?(21)
tef? this will block homescreen layout customization with 3rd party apps
blocking-b2g: --- → tef?
There is other bug for 3rd part app arrangement, when I try to arrange m.here.com by customize.json and make production

I got a error message since manifest.webapp not exist:
Invalid JSON file : <GAIA_PATH>/external-apps/m.here.com/manifest.webapp 

we only have update.webapp in m.here.com
(Assignee)

Comment 6

6 years ago
please open other but with this one because it is different in my opinion. This bug is related to zip apps.
(Assignee)

Comment 7

6 years ago
https://github.com/mozilla-b2g/gaia/commit/6a07c86e4fb2f495c645d0680d1776b529fb1b2a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
blocking-b2g: tef? → tef+
v1-train: 7f4ca292cbbbc2388f10aa5527f7cf5309441ea0
v1.0.1: 3488ef36326a386d7389cfcb1a440654cc8888b0
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed

Comment 10

6 years ago
does not make sense to create a regression issue.
Flags: in-moztrap-

Updated

6 years ago
Whiteboard: QARegressExclude

Comment 11

6 years ago
Cannot verify, need steps to blackbox test this issue.

Comment 12

6 years ago
STR:
1. create customize.json and put it to gaia root folder (reference attachment)
2. make production
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.