[BeetleLite] Unable to launch SMS activity from Contacts App

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MWCDemo2013], URL)

(Reporter)

Description

6 years ago
Launch contacts, and create a contact with a phone number.  Save the contact, and then tap the SMS icon next to the phone number in your contact.   No SMS activity is launched.

Is this a Regression of bug 840698?

Logcat attached
02-13 08:55:41.790: I/GonkMemoryPressure(386): Checking to see if memory pressure is over.
02-13 08:55:41.790: I/GonkMemoryPressure(136): Checking to see if memory pressure is over.
02-13 08:55:41.790: I/GonkMemoryPressure(497): Checking to see if memory pressure is over.
02-13 08:55:41.790: I/GonkMemoryPressure(573): Checking to see if memory pressure is over.
02-13 08:55:41.830: I/GonkMemoryPressure(363): Checking to see if memory pressure is over.
02-13 08:55:41.840: I/GonkMemoryPressure(482): Checking to see if memory pressure is over.
02-13 08:55:41.850: I/GonkMemoryPressure(650): Checking to see if memory pressure is over.
02-13 08:55:41.920: E/Sensors(136): BMASensor: type=2,code=0,value=-2
02-13 08:55:41.920: E/Sensors(136): BMASensor: type=2,code=1,value=17
02-13 08:55:41.920: E/Sensors(136): BMASensor: type=2,code=2,value=62
02-13 08:55:41.920: E/Sensors(136): BMASensor: type=0,code=0,value=0
02-13 08:55:42.080: I/IdleService(136): Get idle time: time since reset 418 msec
02-13 08:55:42.080: I/IdleService(136): Idle timer callback: current idle time 418 msec
02-13 08:55:42.080: I/IdleService(136): next timeout 581 msec from now
02-13 08:55:42.080: I/IdleService(136): SetTimerExpiryIfBefore: next timeout 580 msec from now
02-13 08:55:42.080: I/IdleService(136): reset timer expiry to 590 msec from now
02-13 08:55:42.120: E/Sensors(136): BMASensor: type=2,code=0,value=-3
02-13 08:55:42.120: E/Sensors(136): BMASensor: type=2,code=1,value=17
02-13 08:55:42.120: E/Sensors(136): BMASensor: type=2,code=2,value=62
02-13 08:55:42.120: E/Sensors(136): BMASensor: type=0,code=0,value=0
02-13 08:55:42.290: D/wpa_supplicant(777): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 50 4f 4c 4c
02-13 08:55:42.300: D/wpa_supplicant(777): nl80211: survey data missing!
02-13 08:55:42.320: E/Sensors(136): BMASensor: type=2,code=0,value=-2
02-13 08:55:42.320: E/Sensors(136): BMASensor: type=2,code=1,value=18
02-13 08:55:42.320: E/Sensors(136): BMASensor: type=2,code=2,value=62
02-13 08:55:42.320: E/Sensors(136): BMASensor: type=0,code=0,value=0
02-13 08:55:42.320: I/Gecko(136): -*- WifiWorker component: Firing connectionInfoUpdate: ({signalStrength:-64, relSignalStrength:80, linkSpeed:54, ipAddress:"10.250.23.6"})
02-13 08:55:42.520: E/Sensors(136): BMASensor: type=2,code=0,value=-2
02-13 08:55:42.520: E/Sensors(136): BMASensor: type=2,code=1,value=16
02-13 08:55:42.520: E/Sensors(136): BMASensor: type=2,code=2,value=63
02-13 08:55:42.520: E/Sensors(136): BMASensor: type=0,code=0,value=0
02-13 08:55:42.670: I/IdleService(136): Get idle time: time since reset 1009 msec
02-13 08:55:42.670: I/IdleService(136): Idle timer callback: current idle time 1009 msec
02-13 08:55:42.670: I/IdleService(136): next timeout 4294967293990 msec from now
02-13 08:55:42.670: I/IdleService(136): SetTimerExpiryIfBefore: next timeout 4294967293990 msec from now
02-13 08:55:42.670: I/IdleService(136): reset timer expiry to 4294967293999 msec from now
02-13 08:55:42.670: I/IdleService(136): Idle timer callback: tell observer 435fae70 user is idle
02-13 08:55:42.670: I/IdleService(136): Get idle time: time since reset 1011 msec

Repro:
1) install a mwc test build on BeetleLite
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b8d06a2cdca0
Gaia   7d9e1af0cbfd1782b6a052d7caf55344a87a1367
BuildID 20130212121701
Version 18.0

2) Launch Contacts, and create and save a new contact with a phone number
3) Tap the SMS activity button next to the number.   
4) Verify no SMS app is launched, and the button does nothing.

Expected:
- SMS app is launched with phone number

Actual:
- no SMS activity
(Reporter)

Comment 1

6 years ago
reflashed and verified working again from patch in bug 840698
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.