Last Comment Bug 841047 - Strange behavior of Fullscreen button on localization edit page
: Strange behavior of Fullscreen button on localization edit page
Status: RESOLVED FIXED
[specification][type:bug]
:
Product: Mozilla Developer Network
Classification: Other
Component: General (show other bugs)
: unspecified
: All Other
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-13 09:38 PST by Frédéric Bourgeon [:FredB]
Modified: 2013-11-11 18:28 PST (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Floating WYSIWYG (23.14 KB, image/png)
2013-02-13 11:40 PST, John Karahalis [:openjck]
no flags Details
This is the entire viewport. Notice that the first row of buttons is missing. (114.18 KB, image/png)
2013-02-13 13:03 PST, John Karahalis [:openjck]
no flags Details

Description Frédéric Bourgeon [:FredB] 2013-02-13 09:38:47 PST
What did you do?
================
1. Edit any non en-US doc
2. Click the full-screen button

What happened?
==============
The editor goes in full-screen, but the first line of button tools isn't visible in the viewport.

What should have happened?
==========================
All the tools in the editor should be visible in the full-screen mode.

Is there anything else we should know?
======================================
It works well in non-l10n UI.
The button to go back to the non-full-screen mode is on the first line, making impossible to go back to the "normal" mode and so blocks access to save buttons.
Comment 1 John Karahalis [:openjck] 2013-02-13 11:40:25 PST
Created attachment 713538 [details]
Floating WYSIWYG

Noticed another issue while testing this, so I thought I would generalize the bug report out to include it.

In addition to the problem mentioned in comment 0, the Fullscreen button sometimes causes the WYSIWYG toolbar to appear floating on the left side of the screen.

For design, the sign off is pretty simple. The Fullscreen button should work exactly as it does on normal pages, without any of the weirdness described in this comment or comment 0.
Comment 2 David Walsh :davidwalsh 2013-02-13 12:31:41 PST
Can I be provided steps to reproduce, or more browser info?  I'm not seeing either of the side-effects you are:

http://screencast.com/t/XrKMJ9Db7v
Comment 3 John Karahalis [:openjck] 2013-02-13 12:34:59 PST
I am on Firefox 19 / Linux. Try hitting the fullscreen button before scrolling the page at all. This usually causes comment 0. And then try scrolling a bunch and trying again. This usually causes comment 1.
Comment 4 David Walsh :davidwalsh 2013-02-13 12:47:12 PST
Followed the steps provided, can't reproduce.  Please provide a screenshot so I know what I'm looking for, or how it can somehow be prevented.
Comment 5 John Karahalis [:openjck] 2013-02-13 13:03:16 PST
Created attachment 713587 [details]
This is the entire viewport. Notice that the first row of buttons is missing.
Comment 6 John Karahalis [:openjck] 2013-02-13 13:04:49 PST
David: See comment 5 and comment 1.
Comment 7 David Walsh :davidwalsh 2013-02-13 13:39:49 PST
OK, I see it now;  didn't have enough content within the WYSIWYG.  Will look at now.
Comment 8 [github robot] 2013-02-14 13:13:47 PST
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/9b89067777330f28897cd3ea4125669012ea85b0
fix bug 841047 - Fix translation fullscreen issues

https://github.com/mozilla/kuma/commit/f050a7f96cb7f3d056b459c39545fa0c0d249b11
Merge pull request #870 from darkwing/fullscreen-841047

fix bug 841047 - Fix translation fullscreen issues
Comment 9 John Karahalis [:openjck] 2013-02-14 15:34:24 PST
Good stuff. Go David!

Note You need to log in before you can comment on or make changes to this bug.