Last Comment Bug 841078 - FORBIDDEN_IDS in gDevTools is improperly initialized
: FORBIDDEN_IDS in gDevTools is improperly initialized
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Framework (show other bugs)
: 21 Branch
: x86_64 Windows 7
: -- minor (vote)
: Firefox 22
Assigned To: Brandon Benvie [:benvie]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-13 11:03 PST by Brandon Benvie [:benvie]
Modified: 2013-02-20 06:43 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
change FORBIDDEN_IDS initializer to an array of strings (798 bytes, patch)
2013-02-13 11:41 PST, Brandon Benvie [:benvie]
rcampbell: review+
Details | Diff | Review

Description Brandon Benvie [:benvie] 2013-02-13 11:03:37 PST
The Set `FORBIDDEN_IDS` is initialized with two strings instead of an array of two strings. Since strings are iterable, the result is that the characters of the first string are individually added to the set, instead of two strings being added.
Comment 1 Brandon Benvie [:benvie] 2013-02-13 11:41:51 PST
Created attachment 713543 [details] [diff] [review]
change FORBIDDEN_IDS initializer to an array of strings
Comment 2 Victor Porof [:vporof][:vp] 2013-02-13 11:44:26 PST
(In reply to Brandon Benvie from comment #1)
> Created attachment 713543 [details] [diff] [review]
> change FORBIDDEN_IDS initializer to an array of strings

Nice catch!
Comment 3 Rob Campbell [:rc] (:robcee) 2013-02-13 15:08:37 PST
Comment on attachment 713543 [details] [diff] [review]
change FORBIDDEN_IDS initializer to an array of strings

r++++!!!
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2013-02-19 05:52:41 PST
https://hg.mozilla.org/integration/fx-team/rev/06d0fa06a3c2
Comment 5 Tim Taubert [:ttaubert] 2013-02-20 06:43:21 PST
https://hg.mozilla.org/mozilla-central/rev/06d0fa06a3c2

Note You need to log in before you can comment on or make changes to this bug.