JavaScript Error: Applications is not defined in landing page

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

unspecified
x86
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
E/GeckoConsole(  679): [JavaScript Error: "ReferenceError: Applications is not defined" {file: "app://homescreen.gaiamobile.org/js/landing.js" line: 32}]

We have a problem when users touch on landing page because there are dead code not needed
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
Created attachment 713830 [details]
Patch v1

no risk

Removing dead code that causes Javascript errors and listeners not needed
Attachment #713830 - Flags: review?(21)
(Assignee)

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Comment 2

5 years ago
Comment on attachment 713830 [details]
Patch v1

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 807529
User impact if declined: no but less listeners and no error on logs
Testing completed: yes
Risk to taking this patch (and alternatives if risky): no risk, null
Attachment #713830 - Flags: approval-gaia-v1?
(Assignee)

Updated

5 years ago
Attachment #713830 - Flags: approval-gaia-v1?
(Assignee)

Updated

5 years ago
blocking-b2g: tef? → ---
Attachment #713830 - Flags: review?(21) → review+
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla-b2g/gaia/commit/ccc9424f194022c825128acdaf682e3cf2cb2f01
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

5 years ago
Comment on attachment 713830 [details]
Patch v1

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: nothing, but less listeners and no error on logs
Testing completed: yes
Risk to taking this patch (and alternatives if risky): null
Attachment #713830 - Flags: approval-gaia-v1?

Updated

5 years ago
tracking-b2g18: --- → +

Updated

5 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix

Comment 5

5 years ago
Comment on attachment 713830 [details]
Patch v1

Approving for v1-train (v1.1) but not v1.0.1.
Attachment #713830 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train: 1d7d990a5d3340b76ec14470b23d703bacb62382
status-b2g18: affected → fixed
You need to log in before you can comment on or make changes to this bug.