Closed Bug 841373 Opened 7 years ago Closed 6 years ago

Build error with --enable-strip on MacOSX10.8 (clang) : ___cxa_guard_acquire

Categories

(Firefox Build System :: General, defect)

All
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla28

People

(Reporter: pierre, Assigned: froydnj)

References

Details

Attachments

(3 files)

Attached file Build log with error
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201185534

Steps to reproduce:

Building Firefox with --enable-strip on MacOSX Mountain Lion with latest Xcode (4.6).
clang --version gives "Apple LLVM version 4.2 (clang-425.0.24) (based on LLVM 3.2svn)"

mozconfig attached


Actual results:

Build failed (log attached).

Error:
strip libmozglue.dylib
strip: symbols referenced by indirect symbol table entries that can't be stripped in: libmozglue.dylib
___cxa_guard_acquire
___cxa_guard_release
___stack_chk_fail
___udivdi3
___umoddi3
_abort
_ceil
_memcpy
_memmove
_memset
_strlen
dyld_stub_binder
___stack_chk_guard
make[7]: *** [libmozglue.dylib] Error 1


Expected results:

Build should end successfully.
OS: Linux → Mac OS X
In fact I don't really remember why I have --enable-strip in my mozconfig... I removed it and got my XPCOM component with quite the same size as before.

So if you think this bug is not important for Firefox builds, you can simply close it.
Component: Untriaged → Build Config
Product: Firefox → Core
I can confirm this, I see the same for Thunderbird on OS X 10.8. So, --enable-strip is really unusable on 10.8 currently.
Blocks: 809803
Hardware: x86_64 → All
Version: 20 Branch → Trunk
Looks like a simple oversight.
Attachment #830204 - Flags: review?(mh+mozilla)
Assignee: nobody → nfroyd
FWIW, Ray Donnelly from the Tor project said this patch fixed the errors he saw with --enable-strip on OS X.
Attachment #830204 - Flags: review?(mh+mozilla) → review+
It fixes it for me too, thanks for the patch.
https://hg.mozilla.org/mozilla-central/rev/31455f831ed4
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
I know this is fixed, but just wanted to point out that I'm not actually with the Tor Project, I've just been helping them out with some OS X cross compilers.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.