[traceback] HttpServerError: Server Error 500: https://payments-dev.allizom.org/bango/package/181/ Content: {...

VERIFIED FIXED in 2013-02-14

Status

Marketplace
Payments/Refunds
P1
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Victor Carciu, Assigned: Keir Kettle)

Tracking

({regression})

2013-02-14
x86_64
Windows 7
regression
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130211 Firefox/21.0

Steps to reproduce:
1.Open MP-dev and go to Dev Hub
2.Select a paid app and go to "Compatibility & Payments"
3.Go to "Compatibility & Payments" and click " 	Add or manage payment accounts" link
4.Select an already added account and click "Modify" link

Expected results:
Account details are displayed and the user is able to modify the account.

Actual results:
"There was a problem contacting the payment server." error is displayed

Please see screencast for this bug: http://screencast.com/t/ZJW4btWQJomO

Comment 1

5 years ago

HttpServerError: Server Error 500: https://payments-dev.allizom.org/bango/package/181/
Content: {"error_code": "ACCESS_DENIED", "error_data": {}, "error_message": "ACCESS_DENIED: Invalid credentials. You are not authorized to call this method"}


Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "amo/decorators.py", line 160, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 152, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 160, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 152, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 33, in wrapper
    return func(request, *args, **kw)
  File "amo/decorators.py", line 131, in wrapper
    response = func(*args, **kw)
  File "mkt/developers/views_payments.py", line 205, in payments_account
    return account.get_details()
  File "mkt/developers/models.py", line 152, in get_details
    .get(data={'full': True}))
  File "curling/lib.py", line 105, in get
    params=kwargs)
  File "slumber/__init__.py", line 103, in _request
    raise exceptions.HttpServerError("Server Error %s: %s" % (resp.status_code, url), response=resp, content=resp.content)
Summary: Cannot contact the payment server when trying to modify a bango account. → [traceback] HttpServerError: Server Error 500: https://payments-dev.allizom.org/bango/package/181/ Content: {...

Updated

5 years ago
Duplicate of this bug: 841375

Comment 3

5 years ago
Keir: can we check that the credentials on the test server have not changed? The username and password on our end haven't changed. This is using the Bango test server from our -dev server.
Assignee: nobody → keir
Priority: -- → P1
Version: 1.5 → 1.1
The test password was changed temporarily but it's back now and our test API access is working again.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
Verified as fixed : http://screencast.com/t/MJqYX2a3z
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

5 years ago
Reproducible again using the original scenario
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Hmm, it does look like the same error:

HttpServerError: Server Error 500: https://payments-dev.allizom.org/bango/package/189/
Content: {'error_data': {}, 'error_code': 'ACCESS_DENIED', 'error_message': 'ACCESS_DENIED: Invalid credentials. You are not authorized to call this method'}

http://sentry.dmz.phx1.mozilla.com/addons/marketplace-dev/group/12260/

The API call is roughtly: client.api.bango.package(self.uri_to_pk(self.uri)).get(data={'full': True})

Updated

5 years ago
Version: 1.1 → 1.2

Comment 8

5 years ago
This is not a Bango issue. This is a Mozilla url.

Comment 9

5 years ago
It's a Mozilla URL connecting to Bango. Bango is returning "ACCESS_DENIED, Invalid credentials. You are not authorized to call this method". Why have the test credentials stopped working?

Comment 10

5 years ago
Can you try now?

Comment 11

5 years ago
No change.

Comment 12

5 years ago
One more try please, it should be fine now.

Comment 13

5 years ago
Yes, working now. Thank you.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 14

5 years ago
Simone, can we get a date for when this will go into Live for our E2E testing in our staging environment?
(Reporter)

Comment 15

5 years ago
Verified as fixed : http://screencast.com/t/yKYRXgqtVQn
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.