Firefox win32 nightly l10n builds are broken

RESOLVED FIXED in mozilla21

Status

RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: unghost, Assigned: glandium)

Tracking

unspecified
mozilla21
All
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Looks like metro landing have broken compilation of Firefox win32 nightly l10n builds. For example, http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-l10n/1360860320.1360860605.21403.gz shows:

e:/builds/moz2_slave/m-cen-w32-l10n-ntly-0000000000/build/mozilla-central/_virtualenv/Scripts/python.exe ../../toolkit/mozapps/installer/l10n-repack.py /e/builds/moz2_slave/m-cen-w32-l10n-ntly-0000000000/build/mozilla-central/browser/locales/../../dist/l10n-stage/firefox ../../dist/xpi-stage/locale-fr \
		
make[2]: Leaving directory `/e/builds/moz2_slave/m-cen-w32-l10n-ntly-0000000000/build/mozilla-central/browser/locales'
make[1]: Leaving directory `/e/builds/moz2_slave/m-cen-w32-l10n-ntly-0000000000/build/mozilla-central/browser/locales'
Traceback (most recent call last):
  File "../../toolkit/mozapps/installer/l10n-repack.py", line 206, in <module>
    main()
  File "../../toolkit/mozapps/installer/l10n-repack.py", line 203, in main
    repack(args.build, args.l10n, args.non_resource)
  File "../../toolkit/mozapps/installer/l10n-repack.py", line 111, in repack
    for e in entries if isinstance(e, ManifestEntryWithRelPath))
  File "../../toolkit/mozapps/installer/l10n-repack.py", line 111, in <genexpr>
    for e in entries if isinstance(e, ManifestEntryWithRelPath))
KeyError: 'metro'
make[2]: *** [repackage-zip] Error 1
make[1]: *** [repackage-win32-installer] Error 2
make: *** [repackage-win32-installer-fr] Error 2
program finished with exit code 2
My waterfall parsing abilities are a little rusty, but didn't these build run fine 2013/02/13?

http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n&maxdate=1360826684&hours=24&legend=0&norules=1
Potentially a regression from bug 840598.
Blocks: 747347
No longer blocks: 755724
(In reply to Jim Mathies [:jimm] from comment #2)
> Potentially a regression from bug 840598.

sorry, incorrect bug number. bug 747347.
(Assignee)

Comment 4

6 years ago
Looking at the l10n-repack code, it means there is nothing under metro in the langpack. So there must be something fishy in metro localization.
(Assignee)

Comment 6

6 years ago
Ah... the l10n builds don't have --enable-metro...
(Assignee)

Comment 7

6 years ago
We just need to add ac_add_options --enable-metro to browser/config/mozconfigs/win32/l10n-mozconfig
(Assignee)

Comment 8

6 years ago
Created attachment 714019 [details] [diff] [review]
Enable metro on windows l10n builds
Attachment #714019 - Flags: review?(jmathies)
(Assignee)

Updated

6 years ago
Assignee: nobody → mh+mozilla

Updated

6 years ago
Attachment #714019 - Flags: review?(jmathies) → review+
(Assignee)

Comment 9

6 years ago
https://hg.mozilla.org/mozilla-central/rev/2e76c3b1feeb
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21

Comment 10

6 years ago
There haven't been any Firefox win32 l10n version built on mozilla-central since February 13th...

Is it because of this issue, or is it a new different one ?
checking for Windows SDK being recent enough... no
configure: error: You are targeting Windows version 0x06020000, but your SDK only supports up to version 0x06010000. Install and use an updated SDK, or target a lower version using --with-windows-version. Alternatively, try running the Windows SDK Configuration Tool and selecting a newer SDK. See https://developer.mozilla.org/En/Windows_SDK_versions for more details on fixing this.

Uh oh.

Armen, are l10n builders not the same as the m-c 64-bit builders?
(In reply to Jim Mathies [:jimm] from comment #11)
> checking for Windows SDK being recent enough... no
> configure: error: You are targeting Windows version 0x06020000, but your SDK
> only supports up to version 0x06010000. Install and use an updated SDK, or
> target a lower version using --with-windows-version. Alternatively, try
> running the Windows SDK Configuration Tool and selecting a newer SDK. See
> https://developer.mozilla.org/En/Windows_SDK_versions for more details on
> fixing this.
> 
> Uh oh.
> 
> Armen, are l10n builders not the same as the m-c 64-bit builders?

They're the same.

Maybe they use different mozconfigs?

Adding coop since he has been looking at L10n work recently.
(Reporter)

Comment 13

6 years ago
(In reply to b.pagani from comment #10)
> There haven't been any Firefox win32 l10n version built on mozilla-central
> since February 13th...
> 
> Is it because of this issue, or is it a new different one ?

It's Bug 841740

Updated

a year ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.