Add column to raw_adu to track insertion time

RESOLVED DUPLICATE of bug 834802

Status

Socorro
Database
RESOLVED DUPLICATE of bug 834802
5 years ago
5 years ago

People

(Reporter: selenamarie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Add the column and then add the constraint: 

breakpad=# alter table raw_adu alter column inserted_at SET DEFAULT NOW(); 
ALTER TABLE
breakpad=# \d raw_adu
                     Table "public.raw_adu"
       Column        |           Type           |   Modifiers   
---------------------+--------------------------+---------------
 adu_count           | integer                  | 
 date                | date                     | 
 product_name        | text                     | 
 product_os_platform | text                     | 
 product_os_version  | text                     | 
 product_version     | text                     | 
 build               | text                     | 
 build_channel       | text                     | 
 product_guid        | text                     | 
 inserted_at         | timestamp with time zone | default now()
Indexes:
    "raw_adu_1_idx" btree (date, product_name, product_version, product_os_platform, product_os_version)


This is to help track down a crontabber problem. Change has been made in stage, but will get rolled back during the weekly refresh. 

Maybe make this deferable...

Comment 1

5 years ago
I thought that was already a bug for this?
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> I thought that was already a bug for this?

You're welcome to mark the dupe if you know where it is...

Comment 3

5 years ago
Bug 834802 sounds a lot like it would be the same thing - and I found it with a https://bugzilla.mozilla.org/buglist.cgi?quicksearch=raw_adu :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834802
You need to log in before you can comment on or make changes to this bug.