Add GetParentObject() for WebIDL objects with a form owner

RESOLVED FIXED in Firefox 20

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

(Blocks 2 bugs, {regression})

Trunk
mozilla21
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox20+ fixed, firefox21+ fixed)

Details

Attachments

(2 attachments)

We use the parent chain to implement the scope for event handlers, and we broke that.
Assignee

Updated

6 years ago
Assignee: nobody → Ms2ger
Comment on attachment 714038 [details] [diff] [review]
Patch v1

r=me.

We need this on 20, right?
Attachment #714038 - Flags: review?(bzbarsky) → review+
Assignee

Comment 4

6 years ago
[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 824007 (legend)
User impact if declined: possibly broken sites
Testing completed (on m-c, etc.): on inbound; passes try
Risk to taking this patch (and alternatives if risky): pretty low, fix is well understood and tested.
String or UUID changes made by this patch: None
Attachment #714563 - Flags: approval-mozilla-aurora?
Comment on attachment 714563 [details] [diff] [review]
Patch for aurora

Approving for aurora uplift even though this is only on inbound so far with the caveat that this pass testing and get merge to m-c before uplift to Aurora.  With the long weekend in the US it would be great if this can land before Tues 6am Pacific when we do the merge to beta.
Attachment #714563 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/ca388aedb410
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Oh, it does matter what kind of object is returned from GetParentObject.
Based on the documentation all that matters is that from the returned object one should eventually
get to the global.
> Based on the documentation all that matters is that from the returned object one should 
> eventually get to the global.

That's true for all objects that can't be on a scope chain of some script.  As in, everything except nodes.
You need to log in before you can comment on or make changes to this bug.