Inspector should not respect 'pointer-events: none' styles.

RESOLVED DUPLICATE of bug 745489

Status

RESOLVED DUPLICATE of bug 745489
6 years ago
2 months ago

People

(Reporter: Optimizer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR :

1) open this awesome mockup by shorlander : http://people.mozilla.com/~shorlander/files/click-to-play-prototype/clickToPlay-Mockup-03.html

2) an arrow panel will show up saying that Java is disabled.
3) right click on that arrow panel and choose inspect.

Expected result: the div block with class 'ctpPanelContainer' gets selected.

Actual result: the div box with class 'contentArea' or 'mainToolbar' gets selected as the mouse event passes through the arrow panel to make the background node target.

This makes it impossible to inspect the arrow panel, unless you know something about it (like the id or class) or you find the arrow panel by selecting each and every node from the markup panel.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745489

Updated

5 years ago
Blocks: 893669

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.