Intermittent test_peerConnection_bug840344.html | Test timed out.

RESOLVED DUPLICATE of bug 853858

Status

()

P1
normal
RESOLVED DUPLICATE of bug 853858
6 years ago
6 years ago

People

(Reporter: RyanVM, Assigned: jib)

Tracking

({intermittent-failure})

Trunk
x86
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC], [blocking-webrtc+])

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=19744999&tree=Mozilla-Inbound

Rev3 Fedora 12 mozilla-inbound pgo test mochitest-3 on 2013-02-14 11:33:22 PST for push 32327a07b56a
slave: talos-r3-fed-064

424 INFO TEST-START | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html
425 INFO TEST-INFO | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html | Step 0: Instantiate a Peer Connection
426 INFO TEST-INFO | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html | Step 1: Get User Media for Audio and Video
427 INFO TEST-INFO | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html | Step 2a: Add stream
428 INFO TEST-INFO | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html | Step 2b: Create Session Description
429 INFO TEST-INFO | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html | Step 2c: Set Remote Description
430 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html | Test timed out.
args: ['/home/cltbld/talos-slave/test/build/bin/screentopng']
SCREENSHOT: <see log>
431 INFO TEST-END | /tests/dom/media/tests/mochitest/test_peerConnection_bug840344.html | finished in 325105ms
Blocks: 840344
Assignee: nobody → adam
Hmm...looks like we are failing when we call setRemoteDescription with a session description object with that custom SDP.
We also appear to only be failing on fedora opt builds.
(In reply to Jason Smith [:jsmith] from comment #3)
> We also appear to only be failing on fedora opt builds.

and pgo builds.

Updated

6 years ago
Depends on: 841566, 841457
Not actionable without more data from those logging bugs
Whiteboard: [WebRTC]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Reliably(?) stopping at 2c SetRemoteDescription
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Still always times out after 2c, SetRemoteDescription() - success and error callbacks never fire.
Comment hidden (Treeherder Robot)
Any TBPL stars after this comment should contain useful logging information that isolates this problem to a smaller part of the system.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Whiteboard: [WebRTC] → [WebRTC], [blocking-webrtc+]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

6 years ago
Priority: -- → P1
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
So we've had a bunch of reports since we added the debugs.  Do we know anything more about this?  Is this something someone else can help on?  (jib)?
Flags: needinfo?(adam)
FWIW, I've added additional annotation explicitly aimed at diagnosing intermittent timeout bugs as part of trying to track down bug 853858. That patch landed on m-i just a few minutes ago. If it stays in the tree (and I expect it will), then future runs of this will have far better breadcrumbs for figuring out where our call went.

See Bug 853858 comment 3 for details.

I believe Maire is going to ping jib to see if he has some cycles to dig into this bug.
Flags: needinfo?(adam)
Assignee: adam → jib

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853858
You need to log in before you can comment on or make changes to this bug.