GData forgets password

RESOLVED WORKSFORME

Status

Calendar
Provider: GData
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: frommozdev.orghash69@vano.org, Unassigned)

Tracking

Lightning 1.9

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

1. Add a private google calendar and save password using password manager. Make sure the password is saved (options -> saved passwords -> search for entry with your_google_account@gmail.com (Google Calendar))
2. Set master password
3. Restart thunderbird
4. when prompted for master password, cancel it
5. when Google Calendar asks for password cancel it
6. login with your master password (if by this time no more MP prompts sowed,  opening password manager window, it should ask you for master password)
7. open calendar tab and sync your google calendar, it should ask you for google calendar password. Don't type anything and don't check "Use password manager to remember this password" checkbox, hit "Ok" button



Actual results:

saved password deleted


Expected results:

First of all, it should not ask for google calendar password at step 7, it should get it from the password manager, at that point it's unlocked.
Secondly, it should not delete anything, because: 1. "use password manager" checkbox wasn't ticked. 2. no password was entered.
There has been a major rewrite of the Provider for Google Calendar between version 0.32 and 1.0. A vast number of bugs have been fixed during this rewrite, therefore I am closing lots of old bugs that I think might either be fixed or no longer apply to the latest version.

Please read the updated FAQ [1] for details on known issues. If you can reproduce your issue with the latest version of the Provider for Google Calendar and you can't find an existing bug that handles your case, please reopen this issue.

Thank you for your understanding.

[1] https://wiki.mozilla.org/Calendar:GDATA_Provider
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.