Contact list stops loading at certain contact: "TypeError: extraFbItems is undefined"

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: MattN, Assigned: Jose Manuel Cantera)

Tracking

({b2g-testdriver, unagi})

unspecified
All
Gonk (Firefox OS)
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

02-14 21:43:01.206 E/GeckoConsole(  489): [JavaScript Error: "TypeError: extraFbItems is undefined" {file: "app://communications.gaiamobile.org/contacts/js/fb/fb_contact.js" line: 327}]

The contact list fails to completely load in the Contacts app because of the JavaScript error above.

Build ID: 20130212070205
(Assignee)

Updated

5 years ago
Assignee: nobody → jmcf
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
I cannot reproduce in master but providing a patch to guarantee there is no runtime error if extraFbItems is not defined
(Assignee)

Comment 2

5 years ago
Created attachment 714286 [details]
Pointer to GH PR #8122
Attachment #714286 - Flags: review?(crdlc)
ok, reviewing
Comment on attachment 714286 [details]
Pointer to GH PR #8122

minor change without risk
Attachment #714286 - Flags: review?(crdlc) → review+
https://github.com/mozilla-b2g/gaia/commit/c64ee7587c9682856ae653bce95c56aea2daa979
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 714286 [details]
Pointer to GH PR #8122

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: high, Contact list stops loading at certain contact sometimes
Testing completed: yes
Risk to taking this patch (and alternatives if risky): null
Attachment #714286 - Flags: approval-gaia-v1?

Updated

5 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: affected → wontfix
tracking-b2g18: ? → +

Comment 7

5 years ago
Comment on attachment 714286 [details]
Pointer to GH PR #8122

Approving for v1-train (v1.1), but wontfixing for v1.0.1 since we've only had one report of this bug.
Attachment #714286 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train: ef46c141213ad80f2629a268e3a285c2b54fba7e
status-b2g18: affected → fixed
Thanks. The entire contact list loads again after updating to 20130219070200 (beta channel).
Status: RESOLVED → VERIFIED
Blocks: 849186
(we'd like this on v1.0.1 after all, to fix bug 841669)
blocking-b2g: --- → tef+
status-b2g18-v1.0.1: wontfix → affected
v1.0.1: 9d2c03f34d9f08b3ebc30ac06868de0bdc678f9a
status-b2g18-v1.0.1: affected → fixed
You need to log in before you can comment on or make changes to this bug.