All mozharness jobs on inbound are busted due to a problem with mozinstall

RESOLVED DUPLICATE of bug 841777

Status

RESOLVED DUPLICATE of bug 841777
6 years ago
5 months ago

People

(Reporter: jgriffin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
This includes all Marionette and B2G tests.  The error is:

10:10:59     INFO - #####
10:10:59     INFO - ##### Running install step.
10:10:59     INFO - #####
10:10:59     INFO - Getting output from command: ['/builds/slave/talos-slave/test/build/venv/bin/pip', 'freeze']
10:10:59     INFO - Copy/paste: /builds/slave/talos-slave/test/build/venv/bin/pip freeze
10:11:00     INFO - Reading from file tmpfile_stdout
10:11:00     INFO - Detecting whether we're running mozinstall >=1.0...
10:11:00     INFO - Getting output from command: ['/builds/slave/talos-slave/test/build/venv/bin/mozinstall', '-h']
10:11:00     INFO - Copy/paste: /builds/slave/talos-slave/test/build/venv/bin/mozinstall -h
Traceback (most recent call last):
  File "scripts/scripts/marionette.py", line 236, in <module>
    marionetteTest.run()
  File "/builds/slave/talos-slave/test/scripts/mozharness/base/script.py", line 735, in run
    self._possibly_run_method(method_name, error_if_missing=True)
  File "/builds/slave/talos-slave/test/scripts/mozharness/base/script.py", line 694, in _possibly_run_method
    return getattr(self, method_name)()
  File "scripts/scripts/marionette.py", line 161, in install
    super(MarionetteTest, self).install()
  File "/builds/slave/talos-slave/test/scripts/mozharness/mozilla/testing/testbase.py", line 250, in install
    output = self.get_output_from_command(cmd + ['-h'])
  File "/builds/slave/talos-slave/test/scripts/mozharness/base/script.py", line 592, in get_output_from_command
    cwd=cwd, stderr=tmp_stderr, env=env)
  File "/tools/python27/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/tools/python27/lib/python2.7/subprocess.py", line 1228, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
(Reporter)

Comment 1

6 years ago
This is affecting try jobs as well, so doesn't appear to be limited to inbound.
This was a mistake from bug 841777. AIUI the fix has been committed and is waiting on a re-trigger.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841777
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Assignee)

Updated

5 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.