[B2G][OTA] Update – A new update is always available with the latest build and it's updates the system to a previous build.

VERIFIED DUPLICATE of bug 841605

Status

Firefox OS
Gaia::System
VERIFIED DUPLICATE of bug 841605
5 years ago
5 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

318.24 KB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 714500 [details]
logfile

Description:
 Check the system for updates, the new update is always available, but it’s updates the system to the previous build. Build ID:20130212070205

Steps to reproduce:
1. Update “Unagi” device with build ID:20130214070203
2. Open “Settings”
3. Open 'Device information"
4. Check for software updates

Actual result:
A new update is available in notification bar, when it's downloaded it's a previous Build ID:20130212070205

Expected result:
Tap “Check now”, you will receive the following: "This is already the latest version of Firefox OS".

Repro frequency:
100%

Note:
Build ID:20130214070203
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/d1288313218e
Gaia   6544fdb8dddc56f1aefe94482402488c89eeec49
Kernel: Dec 5

See the log.
Please let us know which build you started with and out of which directory. This sounds like a dupe of the bug that I filed yesterday.
(Reporter)

Comment 2

5 years ago
Yesterday I did OTA nightly  Build ID:20130214070203, but today it asked for update over OTA, I updated over OTA, but the build ID was:20130212070205 after update.
Later today I manually flashed my device with latest build ID:20130215070202, but the notification bar still tells me that I need made an update over OTA

Comment 3

5 years ago
It appears to be a duplicate of bug 841605

Comment 4

5 years ago
(In reply to Allen Maxwell from comment #3)
> It appears to be a duplicate of bug 841605

if so, go ahead and mark it a dupe of that bug below.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841605
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.