[B2G][Contacts] Intermittent issue: "No Name" contact appears in the contact list after manually flashing device to the latest build

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Contacts
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: nkot, Unassigned)

Tracking

({smoketest})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 714589 [details]
log file

Description: Weird "No name" contact appears in the contacts list on the freshly flashed device, when select details it is named Tom, name fields are empty in the edit screen - see screenshots

Repro Steps:
1) Manually flash Unagi to build 2013-02-15-070202
2) Launch Contacts app for the first time
3) Verify FTE screen 

Expected:
*User presented with the screen "No contacts Start adding them now"

Actual:
*There is existing "No name" contact in the contact list

Repro frequency:
*Intermittent issue
*Not able to repro, have already seen same issue on 02/06/2013

Updated from:
Gecko:5d713f67597dfc54928b5a97c8c2cfe4a22ba566
Gaia:6544fdb8dddc56f1aefe94482402488c89eeec49
Build ID:20130214070203

Updated to:
Gecko:006b27724e5fb0fd21960a9e0846eb292466287b
Gaia:21ba59d933c66024cb351c2379315301d5352e0c

*log file and Screenshots are attached
(Reporter)

Comment 1

5 years ago
Created attachment 714591 [details]
main Contacts screen
(Reporter)

Comment 2

5 years ago
Created attachment 714592 [details]
contact details
(Reporter)

Comment 3

5 years ago
Created attachment 714593 [details]
edit contact screen

Comment 4

5 years ago
Issue reproduces on a manually flashed Unagi with the following:

Build ID: 20130226070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/819504e27351
Gaia: 823ae4703347ceb585f5d2de764d9d4138a6e892

Comment 5

5 years ago
Unable to reproduce this issue.

Resolving as Works-For-Me on 3/29 Commercial RIL:
Build ID: 20130329070203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/5cc5df16447a
Gaia: 26b463f14caa11e0fc64fda09a17054da4bea68b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.