Turn off --enable-metro on Aurora after Firefox 21 uplift to Aurora

VERIFIED FIXED

Status

defect
--
major
VERIFIED FIXED
7 years ago
8 months ago

People

(Reporter: mbrubeck, Assigned: lsblakk)

Tracking

21 Branch
All
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox21+ verified)

Details

(Whiteboard: [merge-day])

Attachments

(1 attachment)

Metro Firefox is currently enabled on the Nightly channel but is not yet ready for the Aurora audience.  We want to remove --enable-metro from the win32 mozconfigs on mozilla-aurora before Firefox 21 updates are published to the Aurora channel.
Assignee: nobody → lsblakk
Assignee: lsblakk → nobody
Resetting the assignee to lsblakk, looks like I accidentally unassigned it .
Assignee: nobody → lsblakk
Assignee: lsblakk → mbrubeck
Status: NEW → ASSIGNED
Attachment #715526 - Flags: review?(mh+mozilla)
Attachment #715526 - Flags: review?(jmathies)
Moving because we don't seem to have the right approval flags in the Metro product.  (I'll file a separate bug about that.)
Assignee: mbrubeck → lsblakk
Product: Firefox for Metro → Firefox
Attachment #715526 - Flags: review?(mh+mozilla) → review+
Comment on attachment 715526 [details] [diff] [review]
patch for mozilla-aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 813488

User impact if declined: unstable Metro code ships to Aurora users

Testing completed (on m-c, etc.): reverts a config change that just recently landed on m-c

Risk to taking this patch (and alternatives if risky): Very low risk. We are already building without --enable-metro on all platforms besides Win32.

String or UUID changes made by this patch: None.
Attachment #715526 - Flags: approval-mozilla-aurora?
Attachment #715526 - Flags: review?(jmathies) → review+
Would it make sense to revert changeset 784b9beebe90 from bug 755725 on aurora, so that we have some more time to deal with the fallout?
(In reply to Mike Hommey [:glandium] from comment #5)
> Would it make sense to revert changeset 784b9beebe90 from bug 755725 on
> aurora, so that we have some more time to deal with the fallout?

(bug 755724)

https://hg.mozilla.org/mozilla-central/rev/784b9beebe90

Wouldn't this create a package-manifest.in merge nightmare for aurora?

More generally, has the fall out been that bad? Seems like most issues that have come up have been minor.
(In reply to Jim Mathies [:jimm] from comment #6)
> (In reply to Mike Hommey [:glandium] from comment #5)
> > Would it make sense to revert changeset 784b9beebe90 from bug 755725 on
> > aurora, so that we have some more time to deal with the fallout?
> 
> (bug 755724)
> 
> https://hg.mozilla.org/mozilla-central/rev/784b9beebe90
> 
> Wouldn't this create a package-manifest.in merge nightmare for aurora?

I guess you mean backport nightmare. Good question. Do we backport many changes that require package-manifest.in updates?

> More generally, has the fall out been that bad? Seems like most issues that
> have come up have been minor.

I'm more concerned about the fallout that hasn't been caught yet, but then, we also still have 12 weeks of aurora+beta to find and fix them.
Blocks: enable-metro
Comment on attachment 715526 [details] [diff] [review]
patch for mozilla-aurora

I just completed the merge day steps and had already removed these lines, so patch not needed (thanks for providing it though!)

http://hg.mozilla.org/releases/mozilla-aurora/rev/631304d1cf47
Attachment #715526 - Flags: approval-mozilla-aurora?
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Keywords: qawanted, verifyme
I've added this to my list of bugs to verify before sign-off tomorrow.
Keywords: qawanted
> Firefox 21.0a1 2013-01-31
I wasn't able to launch metro from command line but I was able to launch it in metro mode from the start screen.

> Firefox 21.0a2 2013-02-22
I wasn't able to launch metro from command line nor was I able to launch it in metro mode from the start screen.

Unfortunately I was unable to confirm the command line option because I couldn't seem to get it to work on known working builds. However I at least confirmed Firefox Aurora 21 is incapable of being launched in Metro mode from the start screen. As such I'm marking this verified fixed. Please reopen if you find you are able to launch Aurora 21 in Metro mode.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Blocks: 856823
OS: Windows 8 Metro → Windows 8.1
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.