[B2G][OTA] 1.0.1 Nightly Update reverts phone to a previous build

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
4 months ago

People

(Reporter: amaxwell, Unassigned)

Tracking

({smoketest})

other
x86_64
Windows 7
smoketest

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 714658 [details]
Update Logcat

Description:
While at a Flash Build ID 20130215070202 an update notification appeared. The update reverted thre phone to a previous version Build ID 20130212070205.

Repro Steps:
1) Updated to Unagi Build ID:  20130215070202
2) Apply available OTA
3) Go to Settings > Device Information > More Information
4) obseverve Build ID

Expected:
Build ID:  20130215070202
Kernel Date: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/a9e4f8912607
Gaia   81cc50326cddeb19bc38adc944ab804252ff1a62

Actual:
Build ID:  20130212070205
Kernel Date: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/3f905f0ca9ce
Gaia   ecca2ee860825547d5e1109436b50b74dfe9261e

Repro frequency: 100%

Initial Environmental  Variables:
Flash Build ID:  20130215070202
Kernel Date: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/a9e4f8912607
Gaia   21ba59d933c66024cb351c2379315301d5352e0c

Note:
1) This is a fork of bud 841605
2) A second update notification will update phone to expected build
(Reporter)

Updated

6 years ago
Blocks: 841605
(Reporter)

Updated

6 years ago
blocking-b2g: --- → tef?
Keywords: smoketest
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841605
(Reporter)

Comment 2

6 years ago
This bug is a fork of 841605 per Tony Chung's request
Initial comment needs clarification - was this started with a freshly flased build or a previous build that you performed an OTA to? Your repro steps say updated to so I assuming the latter.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: [B2G][OTA] 1.0.1 Nightly Update takes phone to a previous build → [B2G][OTA] 1.0.1 Nightly Update reverts phone to a previous build
This is not a release blocker but does affect dev/qa and needs to be fixed however it's a RelEng issue along the lines of bug 841605 so marking it as such.
blocking-b2g: tef? → -
Component: Gaia → Release Engineering: Automation (General)
Product: Boot2Gecko → mozilla.org
QA Contact: catlee
Version: unspecified → other
Sorry, I'm not sure why this isn't a DUPE of 841605. Can you elaborate?
(Reporter)

Comment 6

6 years ago
This issue no longer occurs on Commercial RIL build 20130319070203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/406b86b4b515
Gaia: c5a8b6476f0dbc456061227a7801e56634683eb0
(Reporter)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

6 years ago
Issue has resurfaced on Commercial RIL Build: 20130322070202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/5aacf880400b
Gaia: 5a31a56b96a8fc559232d35dabf20411b9c2ca1d

Did not occur for Commercial RIL Build:20130321070203
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Rail, can you shed any light on this ?
Flags: needinfo?(rail)
This happens because all builds has the "beta" channel baked in. See https://tbpl.mozilla.org/php/getParsedLog.php?id=20963378&tree=Mozilla-B2g18&full=1 and search for "B2G_UPDATE_CHANNEL". 

This makes all builds use at http://update.boot2gecko.org/beta/update.xml for updates, which is the channel for manually promoted "dogfooder" builds (they are usually published with some lag).

To make nightly builds stay on the nightly channel the update URL has to be overwritten.

In other words, this is an expected behavior.
Flags: needinfo?(rail)
Also, the desktop update server (aus3.m.o) only offers an update if the buildID has increased, but update.boot2gecko.org doesn't do that (it's only serving a bare file).
If you are not on the nightly branch, this is expected.  Please make sure you are on the nightly branch before running the OTA update.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Assignee)

Updated

4 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.