Bad links for Team Roster on Engagement/Communications page at wiki.mozilla.org

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: latrippi, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17

Steps to reproduce:

Clicked on links on Names of all members in the Team Roster table, on this page:

https://wiki.mozilla.org/Engagement/Communications#Team_Roster


Actual results:

Error message on https://mozillians.org: "Sorry something went wrong ... unexpected error and can't process your request." Refreshing didn't help. Tried all names, same result -- but different URLs.

Leslie Nakajima =>
https://mozillians.org/en-US/u/79nRrOLPwqRFIBadlfPaH6Svwg8

Erica Jostedt =>
https://mozillians.org/en-US/u/EJ

etc


Expected results:

Loaded a profile page on the Mozillians site, I imagine.
(Reporter)

Comment 1

6 years ago
This happened after I created an account on the Mozillians site w/Persona, so I was logged in but still waiting to be vouched for. 

If not logged in, I get a "Welcome, please create a Persona" page.
I can't reproduce your error, Clicking on these links does get me the profile pages when logged in. When logged out it's the expected behavior to get the 'welcome page'.

Can you please try to reproduce this bug? Maybe it was temporary server failure.

Thanks!
(Reporter)

Comment 3

6 years ago
You need to be logged in to https://mozillians.org BUT NOT VOUCHED FOR yet, as noted in my follow up. To reproduce the error, I 

- created a test account with a real email
- confirmed the email address
- which took me to a "profile created waiting to be vouched for" page, where I'm automatically logged in, then 
- went to the communications team roster page in another tab and clicked on a team members name
- got error message again

I took screen grabs of the key steps if you'd like me to upload them?
Reproduced, thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is now fixed, i.e. no 500 error message. Bug 846039 is related.

Note that if unvouched you should not see the profile, unless the profile has been made public.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Verified

Reproduced according to steps in comment 3 and comment 5. No 500 error
Thank you Vuyisile, bumping to verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.