selecting a newsgroup crashes.

VERIFIED DUPLICATE of bug 82595

Status

MailNews Core
Networking: NNTP
VERIFIED DUPLICATE of bug 82595
17 years ago
10 years ago

People

(Reporter: Suresh, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I logged onto my imap account, which is the default account. Then expanded the 
news.mcom.com newsserver and selected mcom.forsale. Boom! it crashes.

Build: Todays commercial "branch" release build and Mozilla "trunk" debug build 
(from late last night) on Win NT. 

I can duplicate this crash at will!

Talkback ids: 31362168 and 31362206.
Stack trace: (from mozilla trunk debug build)

_CrtIsValidPointer(const void * 0x05e819f0, unsigned int 32, int 1) line 1591 + 
14 bytes
_CrtIsValidHeapPointer(const void * 0x05e81a10) line 1622 + 16 bytes
_free_dbg_lk(void * 0x05e81a10, int 1) line 1044 + 9 bytes
_free_dbg(void * 0x05e81a10, int 1) line 1001 + 13 bytes
operator delete(void * 0x05e81a10) line 49 + 16 bytes
orkinHeap::Free(nsIMdbEnv * 0x052cb388, void * 0x05e81a10) line 148 + 9 bytes
morkNode::ZapOld(morkEnv * 0x052cb460, nsIMdbHeap * 0x052cbac0) line 195
morkNode::CutWeakRef(morkEnv * 0x052cb460) line 611
morkNode::CutStrongRef(morkEnv * 0x052cb460) line 552 + 12 bytes
morkNode::SlotStrongNode(morkNode * 0x00000000, morkEnv * 0x052cb460, morkNode * 
* 0x05383790) line 447
morkObject::SlotStrongObject(morkObject * 0x00000000, morkEnv * 0x052cb460, 
morkObject * * 0x05383790) line 100 + 20 bytes
morkHandle::CloseHandle(morkEnv * 0x052cb460) line 117 + 18 bytes
morkHandle::CloseMorkNode(morkEnv * 0x052cb460) line 59
morkNode::cut_use_count(morkEnv * 0x052cb460) line 535
morkNode::CutStrongRef(morkEnv * 0x052cb460) line 551 + 12 bytes
morkHandle::Handle_CutStrongRef(nsIMdbEnv * 0x052cb388) line 395
orkinTableRowCursor::Release() line 153 + 20 bytes
nsMsgThread::GetChildHdrAt(nsMsgThread * const 0x05375030, int 0, nsIMsgDBHdr * 
* 0x05e81a80) line 456 + 11 bytes
nsMsgThread::GetChildHdrForKey(unsigned int 10952, nsIMsgDBHdr * * 0x05e81a80, 
int * 0x00000000) line 996 + 20 bytes
nsMsgThread::GetRootHdr(nsMsgThread * const 0x05375030, int * 0x00000000, 
nsIMsgDBHdr * * 0x05e81a80) line 895 + 23 bytes
nsMsgThreadEnumerator::nsMsgThreadEnumerator(nsMsgThread * 0x05375030, unsigned 
int 10952, unsigned int (nsIMsgDBHdr *, void *)* 0x00000000, void * 0x00000000) 
line 616 + 47 bytes
nsMsgThread::EnumerateMessages(nsMsgThread * const 0x05375030, unsigned int 
10952, nsISimpleEnumerator * * 0x00033300) line 848 + 39 bytes
nsMsgDBView::ListIdsInThreadOrder(nsIMsgThread * 0x05375030, unsigned int 10952, 
int 8535, unsigned int * 0x0012d3ac, unsigned int * 0x0012d3f8) line 3159 + 40 
bytes
nsMsgDBView::ListIdsInThreadOrder(nsIMsgThread * 0x05375030, unsigned int 10952, 
int 8534, unsigned int * 0x0012d3ac, unsigned int * 0x0012d3f8) line 3190
nsMsgDBView::ListIdsInThreadOrder(nsIMsgThread * 0x05375030, unsigned int 10952, 
int 8533, unsigned int * 0x0012d3ac, unsigned int * 0x0012d3f8) line 3190
nsMsgDBView::ListIdsInThreadOrder(nsIMsgThread * 0x05375030, unsigned int 10952, 
int 8532, unsigned int * 0x0012d3ac, unsigned int * 0x0012d3f8) line 3190
nsMsgDBView::ListIdsInThreadOrder(nsIMsgThread * 0x05375030, unsigned int 10952, 
int 8531, unsigned int * 0x0012d3ac, unsigned int * 0x0012d3f8) line 3190
nsMsgDBView::ListIdsInThreadOrder(nsIMsgThread * 0x053
(Reporter)

Comment 1

17 years ago
Nominating for nsbeta1 and adding bienvenu and mscott to the cc list. 
Keywords: nsbeta1
I'm not seeing this with build 2001-06-05-04 on Windows 2000 (trunk).  Suresh,
if you delete the server, exit, and re-add it, and then do the steps again, do
you crash?  We have a problem with the DB, and corrupt .msf files, and until you
delete the .msf again, it keeps crashing.
(Reporter)

Comment 3

17 years ago
I tried on an another profile and it works fine! 
Suresh, I think we can mark this worksforme.  I'm betting this was on an old
profile, and you haven't used news for a couple of days, right?
(Reporter)

Comment 5

17 years ago
yes, this is a old profile, but I've been actively using it everyday. And also I
haven't read those newsgroups for 4-5 days now. 
Suresh, see bug 82595 for what I think your problem was.

Comment 7

17 years ago
yes, what happens is that the threads were messed up four or five days ago, but
you never ran into it because you didn't expand the messed up thread. Then, a
new message arrived in the messed up thread and caused us to expand it on
opening the newsgroup. At least that's the theory.
Suresh can verify (same stack, cause, way to resolve).

*** This bug has been marked as a duplicate of 82595 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dupe (already talked to suresh about this)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.