Closed Bug 842185 Opened 9 years ago Closed 9 years ago

"Remove From History" doesn't work

Categories

(Firefox :: Downloads Panel, defect)

21 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox21 + verified

People

(Reporter: bugmozz, Assigned: cers)

References

Details

(Keywords: regression, Whiteboard: [testday-20130222] )

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130217 Firefox/21.0 ID:20130217031005


[Error Console]
Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDownload.remove]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://app/modules/DownloadsCommon.jsm :: <TOP_LEVEL> :: line 1463"  data: no]
Source File: resource://app/modules/DownloadsCommon.jsm
Line: 1463

Error: aSubject.data is undefined
Source File: resource://app/modules/DownloadsCommon.jsm
Line: 916


maybe regression between 0216 and 0217 Nightly.
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/fb6dd685d3a9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130215 Firefox/21.0 ID:20130215171852
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b16497a56714
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130215 Firefox/21.0 ID:20130215173452
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fb6dd685d3a9&tochange=b16497a56714

Suspected: Bug 816254
Blocks: 816254
Version: Trunk → 21 Branch
Seems I misunderstood one of the review comments in bug 816254 :-S

I've verified that this does indeed work, however I notice that when deleting a download (in this case the only in the list), it seems to try to remove the same item twice:

Downloads: A single download with id flzsqcFmXrNc was removed.
Downloads: A single download with id flzsqcFmXrNc was removed.
Downloads: A download data item was removed.
Downloads: Removing a DownloadsViewItem from the downloads list.
Downloads: The downloads item count has changed - we are tracking 0 downloads in total.
Downloads: Removing the panel's hasdownloads attribute.
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /Users/Christian/Projects/mozilla-central/toolkit/components/downloads/nsDownloadManager.cpp, line 1865
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDownload.remove]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///modules/DownloadsCommon.jsm :: DDI_remove/< :: line 1463"  data: no]
************************************************************

I don't think that's related to bug 816254 though, and I don't see any obvious reason why this happens...
Assignee: nobody → csonne
Attachment #715025 - Flags: review?(bmcbride)
(In reply to Christian Sonne [:cers] from comment #2)
> Created attachment 715025 [details] [diff] [review]
> Access .data on the correct object
> 
> Seems I misunderstood one of the review comments in bug 816254 :-S
> 
> I've verified that this does indeed work, however I notice that when
> deleting a download (in this case the only in the list), it seems to try to
> remove the same item twice:

it's because the download manager listens to history, so looks like we remove the download and history, the latter makes so that we try to remove the download again.
There's something to fixup there, but as you said it's unrelated to logging.
Attachment #715025 - Flags: review?(bmcbride) → review+
https://hg.mozilla.org/mozilla-central/rev/673dd484f5b5
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Tested using the latest hourly from m-c 
cset: https://hg.mozilla.org/mozilla-central/rev/a0c57dffd179

While this bug is 'FIXED', download was removed from the Panel & History Library
there is still this error in the Error Console:

Error: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDownload.remove]
Source file: resource://app/modules/DownloadsCommon.jsm
Line: 1463
      aDownload.remove();

Win7 x64
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #5)
> While this bug is 'FIXED', download was removed from the Panel & History
> Library
> there is still this error in the Error Console:
> 
> Error: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE)
> [nsIDownload.remove]

I don't think it's an actual regression, it's most likely just the error caused by bug 826725 (would assert in a debug build).
I got same Error as the one in Comment 0 on Nightly (2013-02-17) on Windows 7 x64 but I can confirm that the fix is verified on Latest Aurora 21.0a2, "remove from history" works as expected!

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130221 Firefox/21.0(20130221042021)
Status: RESOLVED → VERIFIED
Whiteboard: [testday-20130222]
You need to log in before you can comment on or make changes to this bug.