[OTA][Data Roaming] When 2nd time downloading the update, warning dialog should not come out

RESOLVED DUPLICATE of bug 848260

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 848260
5 years ago
5 years ago

People

(Reporter: ypwalter, Assigned: arthurcc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Please see https://www.dropbox.com/s/9ygfskg9dlfsb2q/Roaming%20UI_Feb%2004.pdf.
Go to last page and the description is like this:
When users download software updates via data connection for the first time, they are warned of potential data charges using a prompt as shown here (unless the OEM service is zero-rated by a local DT Affiliate.)

Notice that it is "for the first time".

*Unagi

*Build Version: 
PVT nightly b2g18 user build
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi/2013/02/2013-02-17-07-02-02/

*STR:
  0. flash the phone for the version stated above. (It would have 2 updates in this version)
  1. Choose required (System) update only
  2. Choose to update now
  3. Reboot
  4. Choose Map update

*Expected result:
   It won't have a warning after you select "download"

*Actual result:
   It have a warning after you click "download"
(Reporter)

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Updated

5 years ago
Component: General → Gaia::System
(Reporter)

Comment 1

5 years ago
It different than the UX spec.
blocking-b2g: --- → shira?
Assignee: nobody → arthur.chen
Created attachment 718315 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8325

Alive, could you help review the change? I've added the test cases although they are disabled for now. Thanks!
Attachment #718315 - Flags: review?(alive)
shira- for now as this behavior seems to be acceptable to end users as well.
Need UX input on whether this is a big concern to must match the UX spec
blocking-b2g: shira? → -
Flags: needinfo?(aganesan)
Comment on attachment 718315 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8325

Let's wait UX final confirmation for this change.
Attachment #718315 - Flags: review?(alive)

Comment 5

5 years ago
I think we should warning user again actually. Because when user reboot their mobile phone means something is happen, Maybe change SIM card or operation accident or system unstable...  (In the meanwhile the operation is be interrupted)

Anyway, since this is about cost. To prevent user forget it by accident or change SIM card or other reasons.I think to warning user again is necessary.
Guys: I'm in the process of setting up my github/flashing unagi setup. (after one more failed attempt, I am getting help with it) I will get back on this before tomorrow.
Flags: needinfo?(aganesan)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 848260
You need to log in before you can comment on or make changes to this bug.