latest Firefox update changes user's home page definition

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: biz, Unassigned)

Tracking

18 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

Started up Firefox


Actual results:

After 30 seconds, Firefox opened with 3 tabs open; each to a different Mozilla page. My home page info was changed to Google search page


Expected results:

Firefox should have opened to my defined home page not Google search page
Hi Bert, sorry you're having trouble.

Prior to the upgrade, was your home page http://www.google.com/firefox? That's the only scenario in which your home page would be re-set (see bug 762966). We did that because that page was no longer being maintained, and the functionality of about:home (the new default home page) was mostly identical.

If your home page was something else, perhaps something else is going wrong.
(Reporter)

Comment 2

6 years ago
My home page was a file on my PC! Also, when I click + for a new tab I used to get snapshots of my Most Visited sites, now it's the Google search page. You guys did this as part of the new upgrade!

Comment 3

6 years ago
Type about:config in location bar then enter browser.newtab.url. What's the value?$
If it's a Google url, reset it. (right click)
(Reporter)

Comment 4

6 years ago
This is what's on that line:
browser.newtab.url;about:newtab
(Reporter)

Comment 5

6 years ago
Also discovered that the update changed my download location from my desktop to my downloads folder. PLEASE leave users' configurations alone when updating Firefox!

Comment 6

6 years ago
Firefox doesn't change anything after the update. Something has corrupted your profile, just change it and export your private data:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

I don't think there is something to debug, it's more a support request.
There is the official support board for such support requests: https://support.mozilla.org/en-US/questions

Comment 7

6 years ago
Please re-open this issue if you can reproduce it with a clean profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Updated

6 years ago
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.