Closed Bug 842430 Opened 10 years ago Closed 10 years ago

BaselineCompiler: Assertion failure: numUnsynced == 0, at ion/BaselineBailouts.cpp:712

Categories

(Core :: JavaScript Engine, defect)

Other Branch
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: decoder, Assigned: jandem)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase, Whiteboard: [jsbugmon:update])

Attachments

(1 file)

The following testcase asserts on baseline compiler branch revision 1c8552cc6ec4 (run with --ion-eager):


test();
function test()
  ({}).abstract;
test();
Attached patch PatchSplinter Review
If we have a bailout and pcOffset == 0 && resumeAfter, we don't want to enter baseline JIT code at the prologue (we want to start at the second op).
Assignee: general → jdemooij
Status: NEW → ASSIGNED
Attachment #716069 - Flags: review?(kvijayan)
Attachment #716069 - Flags: review?(kvijayan) → review+
https://hg.mozilla.org/projects/ionmonkey/rev/f8fb6b436345
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 843444
You need to log in before you can comment on or make changes to this bug.