offline:copied/moved messages disappear from a folder when you go back online

VERIFIED FIXED in mozilla0.9.4

Status

defect
P2
normal
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: grylchan, Assigned: Bienvenu)

Tracking

Trunk
mozilla0.9.4
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

18 years ago
Problem: While offline, if you copy or move a message (doesn't
matter if it has been downloaded or not) to another folder,
then go to the folder where you moved the message to, go online,
you will see the message that was in the folder disappear.

Steps to Reproduce:
1.Go offline
2.copy or move a message from your inbox to another folder
3.go to that folder where the message was copied/moved to
4.verify that you can see the message that was just copied/moved
5.keeping the same folder selected, go online

Actual Result: Messages that were just copied to the folder, disappear
as you go online. You have to click another folder and go back to
the folder, where you copied the messages to, to see the newly copied/moved
messages in that folder.

Expected Result: Messages should not disappear and not force a person
to 'refresh' in order to see those copied/moved messages.

Please see bug 78809 for more additional information on 'disappearing
messages'. David's comments on 2001-06-05 17:42 are insightful.

Builds I used to test this bug were
commerical branch builds
2001-06-05-11-0.9.1/ -windows
2001-06-05-04-0.9.1/ -linux
2001-06-05-03-0.9.1/ -mac

Comment 1

18 years ago
adding nsenterprise keyword
Keywords: nsenterprise

Comment 2

18 years ago
adding nsenterprise+
Priority: -- → P2
Target Milestone: --- → mozilla0.9.4
Assignee

Comment 3

18 years ago
I'll look at this, but as I pointed out in bug 78809, 4.x had this bug as well,
so I don't think it's vital we fix it for the next release.
Status: NEW → ASSIGNED
Reporter

Comment 4

18 years ago
sounds reasonable to me, especially if there were no complaints
in 4.x about this..
Assignee

Comment 5

18 years ago
Assignee

Comment 6

18 years ago
the patch fixes the problem by adding the dest imap folder as a url listener,
which because of existing code, will cause the folder to get updated if it's
open in the UI and gets messages moved to it. I need to test this patch some
more, and figure out why we're doing each copy one at a time, which is a
separate issue, but relevant if we're going to do a noop after each one.
Assignee

Comment 7

18 years ago
OK, I'm happy with this fix now - can I get an r/sr=?

Comment 9

18 years ago
r=naving
Assignee

Comment 10

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Reporter

Comment 11

18 years ago
Commercial trunk builds
2001082403 - win nt 4.0
2001082408 - linux 2.2, mac 9.0.4

Tested the following:
  -drag/drop a downloaded and nondownloaded message
  -selecting messages and using context menu to copy the mesgs to new folder
  -selecting messages and using context menu to move the mesgs to new folder
  -selecting messages and using File toolbar button
  -selecting messages and using Menu item Message|Move Message
  -selecting messages and using Menu item Message|Copy Message

It works fine. After going online, Message dissapears for a 
microsecond then it appears back. No need to click on
another folder to 'refresh' it.

 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.