[Building Blocks][Input Areas] should be updated to the last visual version

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Sergi, Assigned: arnau)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

(Whiteboard: UX-P1, TEF_REQ)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 715478 [details]
Input Area :: Screenshot

The styles for the input area we're currently using across the UI is outdated. The changes that should be applied are:

- Increase the font size in the input field to 8pt (MozTT Regular)
- Increase the font size in the button to 7.5pt (MozTT medium)
- The blue gradient used in the "Send" button has a different color code (#00aacc to transparent).
Assignee: nobody → arnau
Created attachment 715913 [details]
Patch
Attachment #715913 - Flags: review?(igonzaleznicolas)
Attachment #715913 - Flags: review?(igonzaleznicolas) → review+
Component: General → Gaia
Comment on attachment 715913 [details]
Patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: Now matching UX visuals
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): Very low
String or UUID changes made by this patch:
Attachment #715913 - Flags: approval-gaia-v1?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
Comment on attachment 715913 [details]
Patch

Approving for v1-train uplift.
Attachment #715913 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train@1bd6c2239a8f9f88eedf59c794b81a8bfb007add
status-b2g18: affected → fixed
This landing regressed the e-mail app's compose UI, specifically the address input fields.  They have some (clearly less-than-perfect!) trickery going on to accomplish the stuff we do with address bubbles, so it's very important that when making changes to input_areas.css that they be smoke-tested by typing some text in the fields and making sure no text gets clipped.

I'm going to go see if we have an e-mail bug on this already and if not file a new one; I'll have that bug marked as depending on this bug.
Blocks: 846037
Sorry Andrew, this is a weird situation we sometimes have to face when modifying Building Blocks.
I also noticed in Contacts app that some inputs where using BB and others where manually done, so now they have different size.... but we need to fix that for sake of consistency.
Please, let me know if you need any help.
You need to log in before you can comment on or make changes to this bug.