Change sequence of cookies menu dialog

RESOLVED DUPLICATE of bug 569627

Status

()

RESOLVED DUPLICATE of bug 569627
6 years ago
6 years ago

People

(Reporter: VanillaMozilla, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 715486 [details]
Screenshot shows reversed sequence

See attached screenshot.
The cookies section reads:
Accept cookies from sites
    Accept third-party cookies
    Keep until they expire

Notice that "Keep until they expire" refers incorrectly to "third-party cookies" because the antecedent of "they" is "third-party cookies".  Notice that the entry is still rather ambiguous if one chooses "Keep until I close Firefox".  Lack of indentation is perhaps too subtle a clue as to the correct meaning.

It would be clearer if the second and third items were reversed:
Accept cookies from sites
    Keep until they expire
    Accept third-party cookies

The problem does not appear to be specific to the English language, and I don't believe it will require localization.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569627
You need to log in before you can comment on or make changes to this bug.