All users were logged out of Bugzilla on October 13th, 2018

Tapping status bar rapidly causes utility tray to fully slide out

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: janjongboom, Assigned: janjongboom)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Tested in B2G desktop, Unagi and GeeksPhone (harder to reproduce here))

At the moment we'll always add the 'utility-tray' class to the screen onTouchStart. This causes the utility tray to appear and disappear immediately when only doing a touch start and no drag. The disappearing is not immediate because there is also an animation, tapping again while in this animation might cause the utility tray to open completely, which is really weird and caused me to accidentally open the tray a couple of times already.

Desired behaviour should be to only show the utility tray when actually doing the touch move rather than the touch start.
(Assignee)

Updated

6 years ago
Assignee: nobody → janjongboom
Created attachment 715493 [details] [diff] [review]
Proposed patch to only show the utility tray on drag
Attachment #715493 - Flags: review?(janjongboom)
(Assignee)

Updated

6 years ago
QA Contact: timdream
(Assignee)

Updated

6 years ago
QA Contact: timdream
(Assignee)

Updated

6 years ago
Assignee: janjongboom → timdream
(Assignee)

Updated

6 years ago
Attachment #715493 - Flags: review?(janjongboom) → review?(timdream)
Comment on attachment 715493 [details] [diff] [review]
Proposed patch to only show the utility tray on drag

r+, but please squash all commits into one commit with a bug number in the commit comment.

I would like to get UX feedback on the behavior before this is merged. I suspect the "bug" you see is intentional visual/interaction hint.
Attachment #715493 - Flags: review?(timdream)
Attachment #715493 - Flags: review+
Attachment #715493 - Flags: feedback?(jcarpenter)
Assignee: timdream → janjongboom
Hi Tim, thanks for the r+. I doubt whether this was on purpose, but for the UX feedback:

By having this behaviour we also open up for other weird behaviour, like not bubbling events through if you have a click handler on top of screen in your apps, and you get visual feedback when tapping that doesnt hint an activity bar on top.
Who do I need to ping for UX feedback on this?
Josh, can you elaborate on this?
Flags: needinfo?(jcarpenter)
Tim, can you ping someone about this issue for feedback?
Flags: needinfo?(timdream)

Comment 7

6 years ago
Tim is on vacation now. I think Josh is the right person to provide some feedback here. Try to ping him on IRC.
Flags: needinfo?(timdream)
Hi there, sorry for the slow response. 

(In reply to janjongboom from comment #0)
> Desired behaviour should be to only show the utility tray when actually
> doing the touch move rather than the touch start.

Current behavior is correct. We want to make the utility tray more discoverable, so we provide a little hint that it exists when the user taps the status bar. However you are correct that tapping repeatedly should not cause the tray to open. It should instead simply repeat the animation. 

The scope of this bug is to fix that glitch, but keep the rest of the behavior intact. 

Updated bug name to match new scope.
Flags: needinfo?(jcarpenter)
Summary: Tapping the top of the screen causes the utility tray to appear and slide out immediately → Tapping status bar rapidly causes utility tray to fully slide out
Comment on attachment 715493 [details] [diff] [review]
Proposed patch to only show the utility tray on drag

-'ing patch, per feedback in most recent commment.
Attachment #715493 - Flags: feedback?(jcarpenter) → feedback-
Comment on attachment 715493 [details] [diff] [review]
Proposed patch to only show the utility tray on drag

I have changed the behavior of this patch. It still shows the utility tray hint but the double tapping to open the tray has been patched. Please re-r?.
Attachment #715493 - Flags: review?(timdream)
Attachment #715493 - Flags: review+
Attachment #715493 - Flags: feedback?(jcarpenter)
Attachment #715493 - Flags: feedback-
Comment on attachment 715493 [details] [diff] [review]
Proposed patch to only show the utility tray on drag

This is generally correct. Thanks for finding the cause of the glitch, which cause by the fact we didn't reset the values properly after the interaction.

Would you fix all that together?
-- remove the comment on L125-127
-- reset both startY and lastY to undefined
-- remove the startX -- it's not used anywhere

Thanks
Attachment #715493 - Flags: review?(timdream)
Attachment #715493 - Flags: review+
Attachment #715493 - Flags: feedback?(jcarpenter)
Fixed. Ready to merge.
https://github.com/mozilla-b2g/gaia/commit/4656bf49b15fe91cb3b53854a1eb4c39bc11d3ed
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.